USB Codec recognized, but no sound recording.

My USB interface is showing up on the toolbar in Audacity, but I hit record and no sound is being recorded.

Using windows 10 and Audacity 2.1.2(exe)

I did notice when I opened the compatibly settings, it only went up to WIndows 8 and did not show Windows 10. Not sure if that’s the problem.

USB interface

What interface is it?


Behringer X1832 usb

That’s a lot of knobs on that thing.

Do you hear the show with headphones plugged into the mixer and do the mixer flashing light sound meters work?

It appears to be a very fancy stereo mixer. So no multi-channel or complexities. I expect the Main Mix show to appear on the USB connection as a stereo signal. I do know of mixers that don’t work that way, but most do. I also expect the simple stereo drivers to work.

Got the show so far?


The compatibility boxes in an EXE file’s properties are for previous versions of Windows.


Yes sir. I’m getting everything in my ears, just nothing into Audacity.

Now that I got your hopes up, I’m not a Windows elf. You appear to be doing everything correctly.

I brought up the number of knobs partly to be funny, but partly to point up the possibility that even if the analog services are working, it’s remotely possible there is a mixer setting that’s preventing USB sound.

That’s a hint to dig in your instructions…


I actually just got done watching a Youtube video and I think I may have found my problem. There very well may be a button that is pushed in that shouldn’t be, preventing the sound from the board to making it’s way to Audacity :smiley:

The Behringer is a 2 in, 2 out USB inteface that is “USB audio class” compliant. That should work without any driver install on any recent Windows, but often doesn’t.

As all Behringer 2IO interfaces use the same driver, could you tell us if you have installed anything for the Behringer?

An ASIO4ALL driver that is supplied for when the USB audio class driver in Windows doesn’t work, can be found on the Behringer site. However, Audacity has no ASIO support, for reasons of license. Info:

So I don’t think the ASIO4ALL driver will work with the Behringer.


Phew… Didn’t know it was this bad with Win 10. It doesn’t have a “USB audio class 2.0” driver.

You could join the demand for a Windows USB class audio 2.0 driver here:

Maybe the Behringer is a USB 2.0 device and doesn’t work for that reason?

I didn’t install anything with the Behringer.

It was working with my old laptop(WIndows Vista).

That leaves you with the ASIO4ALL driver from Behringer…

Which won’t work with Audacity, afaik.

Now, who will you get mad at?

Behringer, for using a standard solution that has existed since 2009 (UAC2) and always worked well?

Or Microsoft, for deciding this standard was no longer needed in Win 10?

The device “should” work without the ASIO4ALL drivers.

Have you checked in the Windows Sound Control Panel to ensure that (a) Windows can see the device and (b) when there is a signal going through the desk, it shows in the control panel recording meter?

Thank you to everyone who contributed to thread.

I did get it figured out and it is now recording into Audacity.

I had one more question.

Will Audacity record and respond to anything coming out of my board, such as any effects and sound level changes?

If you connect using the USB cable then Audacity will record what you send over the USB cable.

Audacity does not add its own effects while recording.


Cool. Thank you!

Figured out

What was it so we can tell others.


Both of the 2TR/USB buttons were on, but the one on the right need to be off.

Too many buttons.

Back in the Paleolithic, a Reputable Manufacturer made a mixing console that had routing controls after the sound meters. At least once a week, someone would flush a production into the toilet by setting the routing wrong by accident. We took the console apart and disabled the routing.


Good mixer, bad manual…

And you’re lucky it’s still a USB 1.1 device. I should have known that, as it’s a 2 i/o over USB.

Yes sir. I’m glad it worked out.

I got everything else fixed(video editing software, problems with videos not uploading to said software) and then this problem came up. :smiley:

It’s all good now and I’m ready to go!