USB Cassette Capture doesn't record on Macbook

I am using OS X 10.8.4
I just purchased a USB Cassette Capture from amazon in order for me to transfer my music from Digital Audio Cassette to Mp3 or iTunes , I installed the cd on my pc and discover there is link for Macbook user, from there i link to the internet and downloaded the Mac latest version of Audacity 2.0.4 on my mac.

I followed all the tutorial and connected my usb cassette capture device by the accompany usb cable, but while the audacity showing recording and the tape is rolling. when i stop, and play the recorded track, the sound is not coming out.

I tried using my voice to record, it was very good and clear from the outside, using the computer microphone and i discovered that it is the problem with the usb connected devices.

I will really like to know how to use this device with the usb connector, because I guess it will reduce the noise interception that come from recording directly through the external devices.

I have tried to download soundflower but it doesn’t give me an option for a usb input or output from the devices preference.

I need to know which other plug-in or software to download that will give me an option for the required USB Devices

Please do help me out.


It sounds like you need to set the input device in Audacity to the USB device.
Please see this page: Device Toolbar
and this page:

– Bill

Thanks Bill,

I have tried all that you said, please see the attached picture of the outcome on my computer, I couldn’t see the USB Audio CODEC at in all the preferences.
and I couldn’t find the particular audio cassette capture that I use as well.

I hope this will help you to direct me further on what to do
Screen Shot 2013-09-12 at 16.21.08.jpg
Screen Shot 2013-09-12 at 16.17.17.jpg
Screen Shot 2013-09-12 at 16.17.34.jpg

In the “Recording Device” in Audacity Devices Preferences, try choosing the “USB PnP Audio Device”.

Leave the Playback Device at “Built-in Output”.

Note the correct link for the Manual Device Toolbar page is .

You can use the link you are using but as we work on 2.0.5 the Manual you are looking at will change and then won’t fully relate to 2.0.4, which could get confusing.


Hi Gale,

thanks for your help, i have done exactly what you said, please see the attached file for the error message recieved from doing that.

Even though it could be frustrating trying to get through this, but i guess i would still hand on, until i obtain a required result.

hope to hear more option from you guys.

Screen Shot 2013-09-12 at 22.09.40.jpg

If you disconnect the cassette device from the computer, do either of “USB PnP Audio Device” or “BHS 10” get removed? We can only guess what they are, unless you tell us.

If none of those get removed, then your cassette device isn’t recognised by Mac yet, so you will need to address that.

You can try another USB cable. USB cables supplied with USB audio gizmos are often faulty.

Then try playing a tape and see if you get the bouncing meter in Apple Sound Preferences as described on Bill’s page.

Or you can try setting up the cassette device in Audio MIDI Setup. See Bill’s page .


Thanks Gale,

When the cassette device is disconnected from the computer, the “USB PnP Audio Device” get removed from the ‘Recording Devices’ see the attached and

what does that mean?

i want to know if you work with software that could enable you assist a third party taking over the computer remotely to offer the required support in sorting out this sort of issues.

Hope to hear from you soon.

Kind Regards.
Screen Shot 2013-09-13 at 00.11.02.jpg

Then you have identified that “USB PnP Audio Device” is the USB cassette device.

So try quitting Audacity, unplug BHS10 (which I assume to be wireless headphones) then plug-in the cassette device and restart the Mac. Then we can eliminate the wireless dongle as the problem.

Then play a tape and check the meters in Apple Sound Preferences. If there are no bouncing meters then probably your device cannot record audio using its current USB cable. If you set up the device in Audio MIDI Setup using Bill’s page and the meters still don’t bounce, then your device definitely can’t record using its USB cable.

So then try changing the cable and try again.

What is the make and model number of the cassette device? Does this cassette device have a place where you can put headphones in?

What is the make and model number of the Mac (exactly) and what year did you buy it?

You could use the headphones out and the Mac input to record, but not if it really is a “mic” input. You could record if it is a “line” input.

Try recording in Garage Band. If it doesn’t record there either, then it isn’t an Audacity problem.

We’ve given you links to help pages. You can find someone in the phone book to help, perhaps, if you are finding difficulty. I can’t work on your computer for nothing, any more than they will.


Thanks Gale,

I attached the information required,

The information on the package of the USB cassette capture system requirements say:

  • Pentium1V 1.7GHz CPU or above
    -Microsoft Windows XP/Vista

I guess this is the problem though, I will try to get a better version of this devices, maybe that would help.

Thanks so much anyway, you have been so helpful, I will notify you if i find any alternative.

All in all the audacity discovery for me is still a great plus, it worth the time spending in understanding how it works.

Screen Shot 2013-09-13 at 01.18.20.jpg
Screen Shot 2013-09-13 at 01.14.57.jpg

According to your model only has a built-in microphone, so it is not an input you can attach a line-level cable to from the tape deck headphones.

Your headphones port can be used as a microphone if you have an Apple headset, and could be used for an external mic with a suitable adaptor, but that is if no value to you.


Hi Gale,

Thanks a lot for going extra length to help me out. I understand your point very well now. I used my old dell laptop with my portable cassette recorder and an audio cable rather than the USB cable - connected to the microphone port, and it did work excellently.

My only concern is that the tape rolling noise is at the recoding background.

I will get the adaptor and apple headphone to use my MacBook in the future, maybe that would be better with the tape rolling noise somehow.

But I am really grateful that you help me to figure out the issue with my recording.

Thanks a lot.

If it really was a microphone port (rather than a line-in which is actually meant for a headphones feed) it would not be high quality.

Why not try another USB cable? It happens so often that the USB cable supplied with the converter is the problem.



I am using the same cassette player as the op and audacity ( just downloaded ) on my iMac. I have exactly the same symptoms as he had. I do see the input flashing in sound preferences.

Is there any more information on this issue ?

Thanks for your help.

Please use more words to describe your “issue”. Try connecting the USB device before launching Audacity. Change the cable. Please read Recording with USB turntables or USB cassette decks. Set the playback device in Audacity to the speakers or headphones you are using, not to the USB device.