USB Audio Codec Input not showing

Hello, I’m trying to set up my Numark USB turntable using Audacity version 2.3.1 with Mac OS X High Sierra 10.13.6

When I go to system preferences: sound - the input only shows internal microphone. Following the Audacity instructions on their page, going to Audio MIDI Setup, the USB Audio Codec still is not shown. (See my screenshots)

What am I doing wrong here? Using Garageband, I was able to record vinyl. It somehow does allow a USB Audio Codec as an input. I want to use Audacity so it will split tracks automatically. I don’t think Garageband has that feature.

Screen Shot 2019-03-29 at 10.39.41 AM.png
Screen Shot 2019-03-29 at 10.39.54 AM.jpg
Screen Shot 2019-03-29 at 10.39.26 AM.png

Try going to System Preferences > Security and Privacy > Privacy. Click on Microphone in the list on the left and make sure Audacity is checked (has permission to access the microphone). With the Numark plugged in and turned on, go to Sound (preferences) > Input and make sure that USB Audio CODEC is visible and selected.

In Audacity try Transport (menu) > Rescan Audio Devices.

– Bill