Urgent - Aud 3.3.3 build gives error during cmake error code 1

** Visual Studio 2019 Developer Command Prompt v16.11.30

** Copyright (c) 2021 Microsoft Corporation

[vcvarsall.bat] Environment initialized for: ‘x64’

ython was not found; run without arguments to install from the Microsoft Store, or disable this shortcut from Settings > Manage App Execution Aliases.

pkgconf/2.0.3: ERROR: Package ‘2d91722813283545a5bec8be869b6396b7c40537’ build failed

pkgconf/2.0.3: WARN: Build folder C:\Specproject\amop333.conan\data\pkgconf\2.0.3__\build\2d91722813283545a5bec8be869b6396b7c40537\build-relwithdebinfo

ERROR: pkgconf/2.0.3: Error in build() method, line 92
ConanException: Error 9009 while executing meson setup --native-file “C:\Specproject\amop333.conan\data\pkgconf\2.0.3__\build\2d91722813283545a5bec8be869b6396b7c40537\build-relwithdebinfo\conan\conan_meson_native.ini” “C:\Specproject\amop333.conan\data\pkgconf\2.0.3__\build\2d91722813283545a5bec8be869b6396b7c40537\build-relwithdebinfo” “C:\Specproject\amop333.conan\data\pkgconf\2.0.3__\build\2d91722813283545a5bec8be869b6396b7c40537\src” -Dprefix=“C:\Specproject\amop333.conan\data\pkgconf\2.0.3__\package\2d91722813283545a5bec8be869b6396b7c40537”

Restoring global Conan config…

Traceback (most recent call last):

File “C:\Specproject\audmaster333\audacity-Audacity-3.3.3\conan\conan_runner.py”, line 339, in


File “C:\Users\user\AppData\Local\Programs\Python\Python39\lib\subprocess.py”, line 373, in check_call

raise CalledProcessError(retcode, cmd)

subprocess.CalledProcessError: Command ‘[‘C:\Specproject\amop333\conan_venv\Scripts\conan.exe’, ‘install’, ‘C:\Specproject\audmaster333\audacity-Audacity-3.3.3\conan’, ‘–build=missing’, ‘–install-folder’, ‘C:/Specproject/amop333\conan-install-debug’, ‘–output-folder’, ‘C:/Specproject/amop333’, ‘–remote’, ‘audacity-binaries’, ‘–profile:build’, ‘C:/Specproject/amop333\profile-build.profile’, ‘–profile:host’, ‘C:/Specproject/amop333\profile-host-debug.profile’]’ returned non-zero exit status 1.

CMake Error at cmake-proxies/cmake-modules/AudacityDependencies.cmake:202 (message):
Conan failed to install dependencies (1)
Call Stack (most recent call first):
CMakeLists.txt:572 (include)

Configuring incomplete, errors occurred!

Python 3.9 is installed and added to the path. I was able to build Audacity by cloning from github folder but it builds 3.4.x-alpha but I want 3.3.3 so I downloaded the source code from github 3.3.3 release and tried to build it when I faced the error.

Am I missing anything? please help.

I see you have already posted on Discord for Audacity Developers. Perhaps the best channel there for assistance is #dev-channel: Audacity dev

Typically developer and compilation questions are answered there.

Note that for some reason, the developers don’t see compilation issues as “emergencies”. Also note that most of the developers are in a different time zone and likely have already gone home for the day. While you are waiting for a reply you might scroll back through the #dev-channel history. Perhaps someone else has already run into this difficulty.

thank you for the response, I will wait and see if anyone replies.


Check that you have the version of Conan specified in the 3.3.3 build instructions.

Hi Steve,

Yes the conan version was the problem. Thank you it worked.

@steve / @jademan

I am trying to debug Audacity 3.3.3 and tried to send some string using wxLogDebug but its not logging. I understand that it works only during debug mode, but I think its disabled during the customized build. Anything that I can do to enable logging.

See the " BUILDING.md" instructions for how to make Debug and Release builds.

Thanks Steve. eventhough I am able to debug audacity, How I can pass String using wxlogDebug to the Audacity log.

Debugging a wx app is normally done by running a debug build in a debugger and raising debug messages in the debug window using wxLogDebug().
This is most likely what you need if you’re trying to debug the code.

Audacity’s log window is different. It does not require a debug build. wxLogMessage is used to write to the debug window. This isn’t really intended as a normal debugging tool, but rather a way of logging user interaction, such as which importer was used to import a file.

This topic was automatically closed after 30 days. New replies are no longer allowed.