Upgrade to 2.1.0 and no more personal theme


Was using the version 2.0.6 on a Mac running Yosemite 10.10.2 with a personalize theme using a modified ImageCache.png file that was located in the folder ~/Library/Application Support/audacity/Theme.
I tried to install the new version in the same location as version 2.0.6 by updating older files and, after bringing back the previous version (thanks to Time Machine), installed the new version (2.1.0) in a different directory keeping both version available.

In either case, the newest version of Audacity (2.1.0) does show my personal theme while the old version still does.

Is it possible to personalize the newest version theme, and if so, I can it be made?


There is no need to delete ~/Library/Application Support/audacity/ when installing a new version of Audacity. Versions of Audacity before 2.1.0 do not support Yosemite.

You can use the same unofficial procedure as in 2.0.6 to display a custom theme - the process still works https://forum.audacityteam.org/t/old-experimental-theme-support/36966/1

If you have a Portable Settings folder in the folder that contains the 2.1.0 installation, delete Portable Settings then 2.1.0 can use the contents of ~/Library/Application Support/audacity/ .


I did not delete the content of the folder ~/Library/Application Support/audacity/ as it still present and use with the 2.0.6 version.

I’m just saying that I still have 2.0.6 install with 2.1.0.
I’ve tried to install 2.1.0 over 2.0.6 resulting that it didn’t show my custom theme. I bring back the original installation and install 2.1.0 in a different folder letting me the choice to run one or the other.

I didn’t have any problem running 2.0.6 with Yosemite.

All files and configuration are still in place as my personal theme is still there when running Audacity 2.0.6 but not with 2.1.0

What do you mean by deleting the Portable Setting, can you explain?


Audio Unit effects do not work in 2.0.6 on Yosemite.

I just explicitly tested the KDE theme from http://jcsu.jesus.cam.ac.uk/~hdc21/design/audacity/ in 2.1.0 on Mavericks. The theme loads as in 2.0.6.

If your installation of 2.1.0 includes a Portable Settings folder (that exact name) then 2.1.0 will not find the theme (or the audacity.cfg modifed to load a theme) which you have in ~/Library/Application Support/audacity/.


I don’t have such directory “Portable Settings”

I’ve uninstalled 2.1.0, and re-install it, deleting the old version (2.0.6) and still the same, it doesn’t load my theme. You say that you test it with Mavericks, could files related to the theme be located else where with Yosemite?


No. And reinstalling 2.1.0 achieves nothing. If reinstalling actually reset your settings it would stop the theme loading.

What you could do in case your .cfg file is corrupted, is to quit Audacity, open audacity.cfg, delete all the contents then just paste in these two lines at the top:



Did what you suggest but still the same my personal theme is not loaded.
I did not take any chance, I even erase the ImageCache.png file and replace it with a new one without success.

Is there anything else that I can try?


Unfortunately, we cannot see your computer. This feature should work, but it is unsupported in any case.

Are you sure there is only the ImageCache.png file in the “Theme” folder, and nothing else? What language is your Mac running in and what language is Audacity running in?

What is the exact ImageCache.png file you are trying to load? Can you link to it or attach it? Please see here for how to attach files: https://forum.audacityteam.org/t/how-to-attach-files-to-forum-posts/24026/1


See attachment “Directory structure”

My Mac is set with French Canada and Audacity language is set to “System”.

See attachment “ImageCache file”

directory.tiff (139 KB)

Thanks for the attachments but please note that we cannot see TIFF files on the Forum without downloading them.

I notice that Yosemite says it does not fully support French Canada when I set the Mac system language to that.

Regardless, I can load the theme you posted on Yosemite running in Canadian French.

Sorry but I can’t spend more time on this. What you want to do is not officially supported, but there must be some reason that we can’t see for this problem. You could experiment further, for example by creating a “Portable Settings” folder in the folder you run 2.1.0 from. Launch Audacity and let it create a new audacity.cfg in that “Portable Settings” folder. Then quit Audacity and add:


to the audacity.cfg in the “Portable Settings” folder.

Make sure you obtained 2.1.0 from http://audacityteam.org/download/mac.


Let’s say I want to re-install everything from scratch, is there anything else to delete beside the following?

~/Library/Application Support/audacity/*

That should be all that matters. If you had created a custom Audacity temporary directory somewhere then that would still exist after reinstallation as above, but would no longer be used.