Unwanted echo effect on recording

Running version 1.2.6 on Windows XP and when recording from Microphone I get an unwanted echo effect. Anyone any ideas on how to fix?

You are probably recording yourself twice. Once when your voice goes into the computer and then once again when it plays back out to your headphones or speakers. Windows will cheerfully record both depending on the settings in the Windows Sound Control Panels.

Windows Control Panel

There’s always a latency delay between those two services, so you get an echo effect.

Then there’s the Smooth Move of the Week possibility. That’s where you’re recording from the built-in microphone instead of the performance microphone. That microphone will pick up room echoes.


Many thanks Koz.
I will give it a go tomorrow.