Unusably slow Zoom/Draw due to open ATI drivers[SOLVED]

I have been processing vinyl manually with Audacity for several years and have had to change distros recently because of a problem. When Zooming in to display individual samples, some systems slow and response times increase to many seconds. This slowness also persists in the draw tool when changing samples and when paging or scrolling horizontally. This problem has been noted with Audacity 2.0.1 thru 2.0.4 (when compiled from source) in both 32 and 64 bit versions of Ubuntu later than 10.04, Lubuntu 12.04 and later, and Mint 16. Several computers ranging from AMD C60 netbooks to 3.0 GHz Athlon systems were tried with identical results. Even loading a bare system with only IceWM on an Ubuntu Server kernel, while slightly better, was still unusable.

Systems which DO work satisfactorily include Ubuntu 10.04 and Debian Wheezy with the Gnome desktop (32-bit). Even the lowly Raspberry Pi with Raspian (Debian Wheezy, LXDE desktop for ARM) is usable! I am currently stuck on a Wheezy system for Audacity but switching to other computers for everyday processing.

Is there a fix for this problem since I would really like to convert systems over to Linux Mint 16?

TIA, Hal

I have been processing vinyl manually with Audacity for several years and have had to change distros recently because of a problem.

Do tell.

Do tell.

I don’t like artifacts left by automated tools so I capture music from a record played on a Pioneer PL-50 turntable, Sansui 850 preamp and a 1.6 GHz Athlon and Soundblaster Live soundcard running Ubuntu 10.04 and the stock Audacity in that package. The captured WAV file is then moved to another utility system for processing. If not too scratched up, I don headphones and play thru the selection about 2-3 seconds at a time. When a ‘tick’ or ‘pop’ is heard, I back up the selection 50 mS at a time until the noise disappears, place the cursor 150 mS before this, zoom in until individual dots are displayed and choose the Draw tool. Then I ‘page’ horizontally thru the selection until an anomaly is seen in the waveform (usually within 50-100 mS) and draw in a substitute shape in each channel. In severe cases when the waveform cannot be reconstructed noise-free, a zero-amplitude silence is substituted (psycho-acoustic processing). To see how it sounds, I zoom back out press the select tool, choose the area and play the selection again.

For very badly damaged selections, I stay zoomed in to display dots and page along correcting anomalies as they are encountered. Sometimes to find a very low-level noise, I start as above about 50 mS before the noise is not heard and smoothly ‘scroll’ along watching for anomalies and correcting them.

This is NOT efficient, I know but this is a labor of love on old Korean LPs as a legacy for my children and grandchildren. I have spend as much as two months on a 12-cut LP and was worth every minute of work.


Which version of Linux Mint 16 have you tried?
I’ve not noticed any problems with Cinnamon.

The systems that are causing you problems seem to be those that rely heavily on graphics acceleration. What sort of video card are you using? If NVidia are you using the open source or the proprietary drivers?

I tried Cinnamon 64-bit and both 32 and 64-bit Petra and all performed in the same (slow) way on an Acer Aspire One (725-0488) with an AMD C-60. The video driver is the default one during installation. The same computer with Ubuntu 12.04 and upgraded to 13.10 (32-bit) also performed in the same slow manner but with the additional aggrivation of those ‘floating’ scroll buttons that absolutely prohibit smooth scrolling (and drive me nuts).

The video on this system is the embedded AMD Radeon system. Here are some lines from dmesg:
[ 2.521127] [drm] Initialized drm 1.1.0 20060810
[ 2.527205] video: module verification failed: signature and/or required key missing - tainting kernel
[ 2.529377] acpi device:01: registered as cooling_device2
[ 2.529428] ACPI: Video Device [VGA] (multi-head: yes rom: no post: no)
[ 2.529544] input: Video Bus as /devices/LNXSYSTM:00/device:00/PNP0A08:00/LNXVIDEO:00/input/input5
[ 2.610675] wmi: Mapper loaded
[ 2.615847] [drm] radeon kernel modesetting enabled.
[ 2.616656] [drm] initializing kernel modesetting (PALM 0x1002:0x9807 0x1025:0x0740).
[ 2.616727] [drm] register mmio base: 0xF0200000
[ 2.616732] [drm] register mmio size: 262144
[ 2.617793] ATOM BIOS: Acer
[ 2.617885] radeon 0000:00:01.0: VRAM: 256M 0x0000000000000000 - 0x000000000FFFFFFF (256M used)
[ 2.617894] radeon 0000:00:01.0: GTT: 512M 0x0000000010000000 - 0x000000002FFFFFFF
[ 2.617899] [drm] Detected VRAM RAM=256M, BAR=256M
[ 2.617904] [drm] RAM width 32bits DDR

A similar Aspire One (model 722) is functioning Ok with Debian Wheezy 32-bit.


Check to see if proprietary drivers are available - they often perform better than the purely open source versions. I think Ubuntu has an option built in for installing proprietary drivers.

THAT’S IT!!! By default, LinuxMint 16 Petra (64 bit) installed the ‘xserver-xorg-video-ati (recommended)’ driver which has the slowdown problem. By going to Administration → Driver Manager and selecting either ‘fglrx’ or ‘fglrx-updates’ (finally chosen) the problem is solved for this platform after re-booting the system.

For Ubuntu 12.04 (64-bit tested), going to Administration → Preferences → Proprietary Drivers, selecting the ‘fglrx-updates’ and rebooting fixes the slowness problem, but still has the ‘floating’ horizontal scroll which makes smooth scrolling unusable. For Ubuntu 13.10, the Driver selection seems to be missing in the menus, so installation of ‘fglrx-updates’ was made with synaptic and after a reboot this too solved the slowness but retained the ‘floating’ horizontal scroll and therefore unusable.

In conclusion, it seems that the ‘xserver-xorg-video-ati’ driver has a problem with Audacity and that moving to the fglrx driver solves the problem.

Thanks to all.