Undesired limiter effect when recording

I use Audacity 2.2.2 under Win10, recording with a Rode NT1 mic through a Focusrite Scarlett 2i2 (1st gen) interface. No limiter in the recording chain to my knowledge. I installed the latest 2i2 driver within the last year. I record only mono spoken voice tracks, no music, with settings usually 44100Hz / 16 bit PCM.

Problem: When recording a track, maximum recorded volume is capped at -6db as if a hard limiter were automatically operating between the interface and Audacity or within Audacity. Recorded volume on the waveform display is capped flat at -6db, and the recording/playback meter toolbars show max gain -6db regardless of Audacity and Scarlett mic input gain settings… For instance, a test recording with both mic gain settings at max and me yelling into the mic yields waveform peaks clipped flat at -6db and meters showing max levels -6db, but playback sounds very distorted.

 Post-recording, amplification effects like Amplify and Normalize can raise waveform and meter levels of an existing track above -6db up to 0db. The undesired gain limiting thus occurs only when recording, not when editing an existing track.

Note that:

o I can’t find any Audacity Edit>Preferences setting accounting for this.
o Uninstalling and re-installing Audacity had no effect.
o Modifying Audacity’s Effect>Limiter settings (Limit type, Limit db level) had no effect. Recording waveforms remain capped at -6db regardless of the Limiter Type and db setting. This implies that the Limiter effect (correctly) isn’t operating during recording; it operates only in post-recording editing as it should.

Audacity VO gurus Larry Hudson and Paul Licameli have already looked at this problem with no solution.

What cause and remedy do you suggest?

Record the 2i2 in Stereo, (two blue waves) and not Mono. The problem should vanish. The 2i2 is a native stereo device and sometimes they don’t much like working in mono.

Split the track to two monos using the drop-down on the left and delete the dead track.


Last I checked, the Scarlett Solo would work natively in Mono. That’s its job.



Koz: Thanks for your suggestion but – assuming I understood it right – it didn’t work.

I have only one mic input into the Scarlett 2i2. When I add a new Stereo track and record onto it, only the Left channel gets recorded; the Scarlett has no Right channel signal to output and Audacity doesn’t split the incoming signal between L&R channels. (Is there a way to force it to?) The Left channel recording was still limited to -6db despite setting both the Scarlett and Audacity mic gain levels to max.

I’ve had the Scarlett 2i2 for 2-3 years. I have always recorded to mono with it – as VO users almost always do – and don’t recall having the -6db limit problem before recently, nor have heard about such a problem from others. FWIW, I upgraded to Audacity v2.2.2 in June 2018.

If I’m missing your point, how so?

have only one mic input into the Scarlett 2i2. When I add a new Stereo track and record onto it, only the Left channel gets recorded; the Scarlett has no Right channel signal to output

Yes, that’s to be expected. But, the signal won’t be limited.

After recording you can click the little drop-down arrow to the left of the waveform and select Split Stereo to Mono. Then you can click the little “X” to the left of the silent right channel to delete it.

don’t recall having the -6db limit problem before recently, nor have heard about such a problem from others.

It’s a common issue. I don’t know if it’s Audacity or the drivers but there’s a very good reason for it -

Let’s say you’re recording at full-volume from one microphone in mono with your stereo interface. Now, your back-up singer comes-in on the 2nd mic. The two channels mixed to mono can clip (distort) without triggering the clipping indicators on your interface, so you may not notice until after if it’s too late. Audacity leaves headroom for the 2nd channel. So with both channels recording in mono, the digital file won’t be clipped as long as the clipping indicators on the interface don’t come on.

FYI - Peak levels of -6dB or less are not a big deal with digital recording, especially if you’re recording at 24-bits. You can simply boost the levels after recording. Pros often record at -12 to -18dB. (In the old days of analog tape you needed a hot signal to overcome tape noise, but there is no tape noise with digital. :wink: )

Now I think you’re talking across each other. If you record in stereo and one track is limited to -6dB (50%) then it’s broken or there is a very serious mismatch or setting somewhere.

Do you get the red knob at about the same time Audacity clips? If not, then the bitstream is being mismanaged somewhere. Do you get the red knob ever? The knob flashes green while you’re performing to normal volume, right?

Do you use Skype or other chat application? Skype has been known to “manage” your sound for you whether you want it to or not.

Drill down into the Windows sound panels and find out if the Microphone Boost has been turned on by accident.

While you’re in there. Does the Windows bouncing sound meter overload short of the mark or does it overload too early, or some other combination of odd behavior? Audacity gets its sound from Windows, not the device and Audacity does not apply filters, effects or corrections during recording.

I found it valuable to step down through the signal pathway and see which parts act funny.


Koz & DVD Doug:
Thanks for your comments.

The practical problem seems solved for the moment though the cause remains mystifying. After re-downloading and installing Focusrite’s driver for the Scarlett 2i2, new Audacity mono recordings don’t show the previous hard limiting at -6db or other level below 0.0db. I don’t know why the new download should have changed things because the driver version number is the same as what was already installed on my PC.

Regarding Koz’ questions:
– When -6db limiting was happening it did so even with the 2i2 volume knob set at max, which yielded indicator ring color red when speaking at normal loudness. I usually set the knob at 2:00-3:00, yielding ring color green.
– Skype isn’t open when I record with Audacity. And in my Skype settings, automatic mic level adjustment is OFF.

My follow-up questions:
– Where are the “Microphone Boost” and “bouncing sound meter” Koz mentioned? I can’t find them in Windows>Settings>System>Sounds>Input>Device properties or elsewhere.
– After today’s driver download & installation, Windows>System>Sound>Input>Focusrite USB Properties>Default Format options include only 48000hz sampling rate. (Again puzzling because the driver # is unchanged from what I installed this January, which allowed selecting 44,100hz.) What is the effect of mismatch between the driver’s 48000hz rate and using 44,100hz in Audacity? I can’t hear distortion or other problem in playback of tracks recorded with this mismatch.

Thanks in advance for follow-up replies.

What is the effect of mismatch between the driver’s 48000hz rate and using 44,100hz in Audacity?

44100 is the sample rate for Audio CDs. 48000 is the video sample rate. Most apps are completely comfortable with either one, although for perfect transfer, the rates should match. If there is an error, the show may play at the wrong speed.

The video editors I’m familiar with are good with dumping a 44100 sound track into a 48000 timeline. Nobody blinks.

“Microphone Boost” and “bouncing sound meter”

This is what happens on Win7. Right-click the little speaker lower right.

Go to Recording.

The microphone boost thing will take Google. Win7 is the most advanced machine I have. Properties in that panel?

Focusrite’s driver for the Scarlett 2i2

Had to be something like that. The driver is standing in the middle between the device and Audacity. It’s remotely possible all the reinstall did was correct a bad setting. It put everything back to Factory Defaults.

Did we tell you to try a clean start? We should have done that. Shift-Shutdown makes Windows forget all its settings and values and start over. It takes a bunch longer which is why plain Shutdown/Start retains a lot of settings, but is faster.


I had the exact same problem using an hp laptop with windows 10. Finally solved by going to HP audio control, input, turning off HP noise control.