Unable to switch from built in mic to line input

I have a mid 2010 Macbook pro i5. I am unable to switch the input in Audacity from built in mic to line input. I checked the line input in system preferences on my mac, but it doesen’t affect the inability to switch the input in Audacity. :angry:


Do you have connections that look like this?


If you have a 13", then you may have one connection that is expected to switch between Line-In and Headphone Out.

The switching is supposed to happen in Mac System Preferences, but I’m not sure what that connection looks like internally.

I would restart Audacity after you set Mac System Preferences. Audacity checks for new devices when it starts.


Yes I do have those connections

Which connections? The separate line-in and headphones out?

Are you sure you have the latest Audacity 2.0.5 from here: Audacity ® | Download for Mac OS ? Check your version at Audacity > About Audacity.

In 2.0.5 you should be able to choose Line-in in Audacity’s Device Toolbar even if the default input in System Preferences is set to another input.


Also make sure your Stereo/Mono is switched right.

You can get there from the Audacity Tool Bar, or you can go the long way:
Audacity > Preferences > Devices > Recording.

And just to cover it, the Stereo Line-In is the circle with two black arrows.

What are you plugging into your Mac? Cassette player, Home Entertainment Amplifier?


I am having the same problem. I read manuals, tutorials, etc.

My computer is:
Imac OS X version 10.8.5

I am using Audacity version 2.0.5
Audio host is core audio which is only choice
Tried recording first with one line mono cord, then stereo cord below
Using 2 pronged stereo (2 lines) plugged into the headset icon on tape recorder
And into back of imac with only port that is the same size
Only records outside sounds (me)

Im my sys pref my choices on sound are:
Internal microphone built in

I selected audacity, preferences, devices, then it says Host: core audio
Playback device-built in output
Recording-built in microphone
channels 2 stereo

Have a look at the manual that came with the Mac.

If you are saying you only have one 1/8 inch audio port that is both input and output, then all you can do is see if there is a drop-down menu in the System sound preferences “use audio port for: ” . If there is, drop this menu down and select “SOUND INPUT".

If you don’t have that choice, you should buy a USB interface to take the connection from the tape recorder. See: Missing features - Audacity Support .


core audio.png
Is this what you mean? It doesn’t appear that I have choices. Not sure how to do the usb.
apple tv .png

If you had the choice, it would appear on both input and output tab:

If you don’t see that choice then I assume you cannot input audio into the Mac except with a four-position (TRRS) plug such as comes with an Apple-approved headset, or by using a three-position (TRS) to four-position adaptor. I don’t recommend the latter, because this type of input is a microphone input, not a line level input. Trying to send cassette headphones output to this input will almost certainly distort.

If you are not sure what type of audio port you have, please read your computer manual or ask Apple for support.

You have to physically purchase the USB device that comes with a line level input.

When you have done that, connect the device to an empty USB port of the Mac and connect your cassette to the USB device’s line-in input (or configure its input to be line level as appropriate).

Then launch Audacity and choose the USB Audio CODEC input in the third box of Device Toolbar .