Unable to recover unsaved aup3 file

Good day everyone!

I’m currently using Audacity 3.0.2. While I was editing a project I started off about 5 hours ago, Audacity suddenly crashed. Upon opening audacity, Automatic Crash Recovery pops up and shows me the recoverable project. However, pressing the “Recovery Selected” button displays a pop-up error saying “Audacity failed to read from a file in C:” (system drive), and now I can’t recover my file.

I have already tried freeing up my space from the system drive and all other drives I have installed on my laptop. The error still displays.
I can see the unsaved aup3 files in the SessionData folder of Audacity, but I don’t know how to recover the project from here.

I would appreciate any help or insight, as this project is due soon.

Vince.

If you have an .aup3 file that fails to open and you care to zip it up, upload it a public file sharing service such as dropbox or google drive, and post (or PM me) a link, then I’ll take a look at it.

This would be it: https://drive.google.com/file/d/1IOnQ01wJDrEVJZo5uW9wwksU4tETmsjl/view?usp=sharing

Vince,

I took a quick look at your file. You are getting a “sqlite3.rc”: “101”,“sqlite3.context”: “SqliteSampleBlock::Load::step” error.

I tried some tricks on this file that have worked with other projects in the past with similar issues, but no joy. I will spend more time on this later and I hope to get back to you tomorrow.

Vince,

I was able to recover your file. I PM’d a link to you. Please acknowledge receipt of file. Thank you.

Hi!
I have the same problem as him.
I spend 4h creating an audio project and I didn’t save it, i know… Then, my computer had some problems and it was blocked. After searching during hours I found my project but it is saved in sqlite format, its name is “New Project 2022-11-05 21-51-24 N-1.aup3unsaved”.
Can you or anyone who knows about it help me please?
I’m desperate…

After backing up the file, you can try changing the file extension from .aup3unsaved to .aup3, then moving it to a working directory on the same machine. Do not use a cloud drive.

Hello, I’m having the exact same problem. Do you think you could help me?

The same as vinceleval or aisite ?

What happened for me is that I shut off my computer, and when I opened it up the files were gone. I tried a manual recovery but the files aren’t working for some reason. I’ve made a post about it on my account but also it says I can’t post a link in here. [maybe this will work?](https://drive.google.com/file/d/1f0Yw4XOvgZY4TBeCM3LzpcBxpWuwWt_E/view?usp=share_link)

I initially had 3 files but when I tried to save them, the other two got automatically deleted.

So sorry, there is nothing in there to recover. Your .aup3 file is the same size as an empty project. I renamed it to *.aup3 and that is all I got - an empty project. That is all I have to offer.

Hi Jade,

You’ve been a great help for a lot of people on this forum. That’s really generous of you. I have kind of the same problem. A few weeks ago I worked on a project in audacity 3.1.3 on a Mac. I saved the project on my hardrive. Unfortunately it won’t open again. Can you please help me to reopen it. Thanks a lot in advance. There’s a link for the file attached.

{
“timestamp”: 1680699401,
“event_id”: “d06b38147e5c4244a96be37f68fc2cec”,
“platform”: “native”,
“release”: “audacity@3.1.3”,
“contexts”: {
“os”: {
“type”: “os”,
“name”: “Macintosh”,
“version”: “10.16.0”
}
},
“exception”: {
“values”: [
{
“type”: “Error_Opening_Project”,
“value”: “Failed to open database file:\n\n/”,
“mechanism”: {
“type”: “runtime_error”,
“handled”: false,
“data”: {
“sqlite3.rc”: “11”,
“sqlite3.context”: “DBConnection::ModeConfig”,
“sqlite3.mode”: “PRAGMA .page_size = 65536;VACUUM;”,
“log”: “14:56:41: DBConnection SetDBError\n\tErrorCode: 11\n\tLastError: Failed to set page size for database /\n\tLibraryError: database disk image is malformed\n14:56:41: DBConnection SetError\n\tErrorCode: 11\n\tLastError: Failed to open database file:\n\n/\n\tLibraryError: (11): database disk image is malformed\n”
}
}
}
]
}
}

The link is:

https://drive.google.com/file/d/1KHAvl3S7wpNnlwE2nGsyY3W1eHSdqWmu/view?usp=share_link

Thank you. :grinning: So that “sqlite3.rc”: “11” thing confirms that your project is corrupt. I am am no longer doing the project recovery thing except in very rare cases - rare enough that the recovery tools actually fail. Unfortunately, MacOS cases are not rare enough, so you are going to have to find some other kind soul to help you out. May I suggest that you start close at home and find a friend with a Windows machine who can follow the procedure: Corrupt or Otherwise Broken Audacity Project Recovery

There is also a chance that gguzman over on Discord might help: Audacity

Thanks a lot Jade :slight_smile: I will give it a go with a windows computer!

Hello! I lost a file due to system crash while editing. I attempted to change the file type and it did change it to an audacity project file. However, it wont open in audacity. No matter how I try to open the file audacity just says “cannot import aup3 format, use file > open instead”. Doing that gives me the same error. Is there anything you can to do to help? It took a very long time to record this particular project. Thank you

It is unlikely you are going to get this file to open in Audacity. You can try Corrupt or Otherwise Broken Audacity Project Recovery, but I don’t think it is going to recover any useful data for you.

Okay I’ll try it just in case. Thank you for taking the time to answer!

Hi jademan
I have been 4 hours trying everything to recover my Audacity Unsaved File, which it included A Music Trakc, and 2 Mono Voice Recordings. Audacity crashed, and the recovery box pop up, but it did not recover anything. I do have the 3 files located and I have been trying to drag them or import them to audacity but its not reading them. Please please please help me out to recover my work. IT would be the world to me.
How can I give you these 3 files so you can review them, and possibly sending that back to me fixed? I can comission you. Please respond with help or contact me to [edit: please don’t post email addresses or other personally identifying information]

Yep. Sorry. Thanks for the vote of confidence - I don’t do this anymore. You will have to re-read the prior posts for instruction and inspiration. Good luck.