Unable to record with Tascam US2x2HR -Audacity Windows

I got a brand new TASCAM US2x2HR audio interface and tried transferring a cassette on Audacity version 3.2.1 Windows 11 Pro 22H2 OS Build 22621.1105. Laptop is ASUS-UX371 11th Gen Intel(R) Core™ i7-1165G7 @ 2.80GHz and 16GB RAM.
Windows automatically downloaded US2x2HR driver on connecting the TASCAM.
I selected this in Audio Setup as my Playback and Recording device. The cassette deck is a Nakamichi CR7A
I was able to monitor the input on the TASCAM and tried record on Audacity. Visually the recording seemed to happen but on playback all I could get was very garbled and sporadic sounds occasionally with some clarity (for less than half a second)
I tried (in Audio Settings) MME, Windows DIrect Sound and Windows WASAPI but no luck, the sound is still garbled and drops like crazy.
What am I doing wrong? The sample rate is 44.1khz and buffer size is 256 samples… should this be changed?
I must mention everything works with the same TASCAM set up with my Macbook Air 2015…
Would be very grateful for any pointers and suggestions…

So it may be worthwhile double-checking the sample rate for all of the actors. This would be the Project Rate in the lower left-hand corner of the Audacity screen, the Sample Rate settings in the TASCAM software and the Sample Rate Settings in Windows Sound Control Panel: Run Windows-R, mmsys.cpl, > Recording/Playback tabs > TASCAM > Properties > Advanced Settings > Default Format. These should all be set to the same value for every input/recording/output/playback device. I would start with 44.1kHz, then try 48kHz.

It doesn’t seem that the tape deck plays any role in this issue. However, do you have the same issue with an alternate signal source?