Unable To Record With Blue Microphones[SOLVED]

Just bought a Blue Spark Microphone and have found that each time I try to record I receive a message that states “Error While Opening Sound Device. Please Check The Input Device And The Project Sample Rate”

I have another microphone (Samson CO3) which works fine and the settings are set exactly the same. I have checked the relevant section on the Audacity help page but cannot get it to record.

Also, when I tried another program (Total Recorder) the program crashed as soon as I hit Record.

Prior to buying this Mic I bought another Blue microphone (Nessie) and experienced the same issues which is why I changed it for this one thinking it may have been faulty.

Does anyone use Audacity with a Blue microphone?

Appreciate any help.


The Blue Spark (or the C03) won’t plug directly into a computer. :frowning:

What kind of connection/interface do you have?

Studio condenser mics require 48V phantom power and a low impedance balanced (XLR) connection. You can get an audio interface with a microphone input and phantom power ([u]example[/u], [u]example[/u]). With that setup, Audacity (and Windows) won’t “see” the microphone, they will see the interface.

Or, you can plug into a microphone mixer (as long as it has phantom power), and then plug the mixer’s output into line-in on a soundcard (not into the mic input on a laptop).

You can also get “studio style” USB condenser mics that have the USB interface built-in. A high quality USB mic is usually the most economical way to get high a quality recording. But, there are limitations, such as generally using one mic at a time, so no stereo or multi-tracking. And, you can’t use a USB mic live with a mixer or PA system. (Samson and Blue both make USB mics.)

Hi, thanks for your reply.

The CO3 works fine plugged into my PC USB it’s just the Spark that I can’t get Audacity to work with.

It (Spark) powers up OK and works fine plugged into my iPad.

Neither mic requires independent power sources. USB is all they require.

Even though the settings within Audacity are the same as those I use with the CO3 I cannot get the Spark to work due to that error message.

What project rate do you have bottom left of Audacity? Try setting it to Spark’s native rate (44100 Hz).

What host do you have in Audacity Device Toolbar ? Try MME. If you have Audacity set to record in 2 (stereo) input channels, try mono.



I have it already set to 44100HZ and have tried numerous settings such as MME and changing from stereo to mono. I have also tried different HZ settings but to no avail.

What I don’t understand is why my CO3 works fine and yet the Spark with similar settings gives off the error message I mentioned.

Prior to the Spark I had the Blue Nessie with exactly the same issue. I sent that back thinking it was either faulty or incompatible but find exactly the same issue with the Spark.

The Spark works fine with my iPad yet is designed to work with PC’s and iPad/iPhone.

Strange how when I tried it with Total Recorder it crashed the program each and every time I pressed the button to record.

Exactly what version of Audacity and Windows do you have? Please see the pink box at the top of this page.

Are you using a USB hub with other devices connected to the hub? If so connect to a spare port. Try a different USB port.

Are you sure the USB ports are USB 2.0 or higher ( http://bluemic.com/spark_digital/#/specs/ ) ?

Have you been into Windows Device Manager and checked the Universal Serial Bus controllers? If there are yellow exclamation marks there you will want to address that. You can right-click over a device and try updating the drivers, or uninstall it (anything there that is not a connected USB device should reinstall itself when you restart Windows).

Also have you asked here: http://bluemic.com/salesandsupport/servicerequest.php ?


Hi Gale.

I use Audacity 2.0.5 (.exe install) with Windows 7

I have two USB 2.0 ports at the front of my PC which I use to plug in the mics and my iPhone etc. There are several USB 2.0 & 3.0 at the rear of my PC which I only use for permanently plugged in devices.

When testing the Blue Spark I tried it in both the front USB ports but to no avail.

I have now plugged it into a rear USB 2.0 port and it works. I then tried it in a USB 3.0 port but received the same error message in Audacity as per previous.

I don’t understand why the front USB’s are not recognising the Blue Spark even though they recognise and work with the CO3 and iPhone etc.

There is no yellow exclamation marks on any of my USB ports.

However, it now works which I am pleased with.

Thanks for your help and replies, much appreciated.

Hmm. I think only Blue could answer that, but I marked the topic as (kind of) solved.