Unable to record [SOLVED]

I have been successfully using Audacity for several years.
I just installed 2.0.6 on my new windows 8 PC with exe installer. The record function does not work. The cursor flickers and remains at the start of the track.
It will play existing recordings as normal.
A message comes up as follows: “Latency correction causes audio to be hidden before zero… use time shift tool…”
I tried various remedies in the faqs.
I have Audacity 2.0.6 working normally on another computer with Windows 7.

If you have turned Sound Activated Recording on by accident in Transport Menu, turn that item off.

If you are using the Windows WASAPI host to record computer playback, play the stream before pressing Record.

Otherwise, try shutting down the computer, wait then start the computer. Use the WIN + X menu if you are on Windows 8.1 as this will do a complete shutdown.


Sorry none of your suggestions solves the problem.
I now find that the record function sometimes starts but only if there are two or more tracks running and I have clicked “snyc-lock tracks”, but the audio signal doesn’t get through and nothing is recorded.

I have 2.0.6 running satisfactorily on a Windows 7 laptop but it won’t work properly on my windows 8 PC.
I compared the two versions. There are differences.

In windows 8:
WASAP: speaker options = realtek; digital realtek; digital optical. mike options = ditto
MME: speaker options = sound mapper (won’t select); realtek; digital realtek; digital optical. mike options = not available.
Window Direct Sound: primary sound driver (won’t select) others as above. mike options = not available.
Clicking record in MME and Windows Direct Sound produces error message: “please check recording device settings and project sample rate”.
Clicking record in WASAP produces error message: “Latency correction”

What are you trying to record?

Thank you for your reply.
In the last five minutes my audacity programme seems to have sprung to life.
I don’t know what I have done to make it work.
I have spent a week trying to get to the bottom of the problem.
All the faults that I reported in my last posting have resolved themselves.
I hope you won’t now think I have been wasting your time.
How can I be sure that it will continue to operate correctly?

It might help if you confirmed what you are trying to record.

I don’t know what you mean by not being able to select Sound Mapper or Primary Sound Driver in Audacity Device Toolbar, but I suggest you go to the web site of your computer manufacturer (or the motherboard manufacturer’s site if you built the computer yourself) and get the latest Windows 8 audio drivers for your exact computer (or motherboard).

Then shut down and reboot the computer, follow the steps at http://wiki.audacityteam.org/wiki/Mixer_Toolbar_Issues#vistacp to show and enable all your devices, then try again in Audacity.


Thank you.
I carried out the instructions given on page 5 of “Mixer Toolbar Issues” under the heading “Recording Settings”.
Audacity is now working perfectly.

Good. I will mark this [SOLVED] then and lock the topic. If the problem comes back, please check your audio drivers as suggested above.

Feel free to start a new topic if you need more help.