Unable to record internal audio with Win11 & 3.1.3

I have a new laptop with Windows 11 and Audacity 3.1.3, but I am unable to get it to record internal audio. I am an experienced Audacity user, but on Windows 7 with Audacity 2.3.2. Ive tried every setting that I can find to get this to work but I have come up empty. WASAPI/MME/Windows DirectSound all don’t work. Stereo Mix is up to date and enabled in Windows. Not sure what to try next, any help is appreciated, thanks.

I’m also a longtime Audacity user, having a similar problem with a new PC (Lenovo Yoga) that I just bought with Windows 10 Pro installed, using version 3.1.3. The PC’s motherboard has an imbedded sound card. I’ve also attempted recording with different settings; Windows WASAPI, Direct Sound & MME as audio hosts and MIcrosoft Sound Mapper for input.

So now there’s two forum members that will appreciate any help that you can give us. I’m attempting to record streaming audio content.

You may need to give Audacity permission to access the recording device (“microphone” or any other audio input). See: https://manual.audacityteam.org/man/error_opening_sound_device.html#W10mic

I have the permission on, it picks up microphone audio no problem.

One major detail I forgot to mention is, I have my headphones plugged in. Now I was able to record no problem with the headphones unplugged, I am always using my headphones, so I didn’t realize it worked fine without them plugged in.

With the headphones plugged in I pick up microphone audio only with settings MME/Stereo Mix, which doesn’t pick up microphone audio when the headphones are unplugged and records properly.

I tried turning on Software Playthrough but that didn’t work.

The best information I have is here: https://manual.audacityteam.org/man/tutorial_recording_computer_playback_on_windows.html
The “WASAPI loopback” method is usually the best option.

Thanks for the help, it seems to be a Windows issue, as I tried other software with he same result. Not sure why I got a new laptop when I have to continue to use the old one lol.

Same with me @CClark. Audacity works perfectly on my older PC with Windows 10 Pro installed. I installed Windows 10 Pro on my brand new laptop. Every function works perfectly EXCEPT for Audacity 3.1.3. I’ve tried everything from the online instruction manual but with no success yet.

Good luck to you. If you figure it out, please don’t hesitate to share what solution resolved your problem.

Hmm… What did your computer vendor(s) have to say ?