Unable to record at 768 kHz on Windows via ASIO

Hi people.

Long story short, I build Audacity for Windows with ASIO support from the latest master at the time of writing. I have an RME ADI 2 PRO FS which is capable of 768 kHz recording an playback. The trouble is, when I set this sample rate both in ASIO control panel and in Audacity, the device drops back to 384 kHz for some reason. Can someone help me figure out why?

Here’s what I found out in Audio Device Info:

Device ID: 12
Device name: ASIO MADIface USB
Host name: ASIO
Recording channels: 2
Playback channels: 2
Low Recording Latency: 0.000725624
Low Playback Latency: 0.000725624
High Recording Latency: 0.000725624
High Playback Latency: 0.000725624
Supported Rates:
  1. Have you tried recording at 768 kHz with other software? Does it work at 768 kHz in other software?
  2. Does it matter? Do you really need to use higher than 96 kHz?

Not directly related to your question, but I found an informative review of the RME ADI-2 Pro here: https://www.hifizine.com/2018/07/rme-adi-2-pro-technical-overview/


Maybe You already did it but I try to figure out.
So when You create a new projet in Audacity the default sample rate is 44100 hz You can see in the left corner down,the maximum is 384000 but you can write it manually the 768000hz what you wish in this timey or you can set the default sample rate in the preference menu in ‘quality’ tab,choose the ‘other’ and you can type 768000hz what will keep the project and the RME card the same sample rate.

hope it helps!

(another person who lost betwen sample rates) :smiley:

  1. Not really, because I’d have to buy that piece of software, but I know that playback works at this SR by testing on Mac. However, neither Win, nor Mac and Linux record ad this sample rate.
  2. Yes. Don’t want to go into details of this project, but I need it for measurements and for recording some HF audio that will be slowed down 10x

I did try it and it didn’t work, otherwise I wouldn’t have written in, but thank you for doing a sanity check on me :smiley:

Did you read that link that I posted about the RME ADI-2 Pro? According to that, the best ultra-high frequency response is at a sample rate of 384 kHz.

I know it is not a solution but You can download and try Reaper software for free and You can test the record.

Yep. It does work and it passes 32-bit test. Thanks

I am also testing one 768khz converter,unfortunately not with the RME ADI 2 PRO,the price is to high to my wallet.
So I hear difference in a quality some cases if I go higher sample rates with soft synths,for example Native Instruments Reaktor,or Massive.
Can You please test any software synths or recording sound with microphone any source in 384khz - 768 khz is it make any noticable difference with RME?


It makes a difference when applying any sort of correction that would benefit from high sample rate (noise reduction, time stretching etc.)

But once I have a clear signal, I’d downconvert to 192 kHz because accoridng to spectrum analysis, my microphone+preamp doesn’t record anything past 40kHz that isn’t noise, so 96 kHz would be the bare minimum to get an accurate recording. Does that make sense to you?

Can you demonstrate that benefit? I don’t see any improvement in noise reduction or time stretching.

Try the following:

  1. Record at the highest sample rate possible
  2. Use SoX to resample the recording file with high quality settings, then do the following on two files separately
  3. Select the same region in both files as your noise profile
  4. Instead of reducing the noise at first, leave the residue and export
  5. In a new project, subtract one residue from another by doing phase invert. You should hear the difference in 20-20000 range

Feel free to do the same but with normal noise reduction. However, resampling also leaves artefacts in the hearing range, so you should also get a snapshot of those and subtract it from the signal you get

As for time stretching, it would take too long to explain, but a practical application of high sample rate recording was done for How To Train Your Dragon franchise. They recorded animal noises and slowed them down significantly (4-10 times). With low sample rate recording (below 88.2) it wouldn’t have sounded nice in the finished product

How do you know that the “difference” isn’t due to Noise Reduction working better at the lower sample rate?

The reason why this is probably the case, is that the frequency band of the noise profile are much narrower (more specific) at lower sample rates.

And here comes my subjectivity, because on lower sample rates, more “good” signal gets chopped off, so it works better for me

Did you ever get it to work at 768kHz or are you still limited to 384 . thkx

I was able to record 768kHz on Windows using WASABI.

Audacity version 3.2.3
Windows 10 Pro
Capture card: TI-ADC6140EVM-PDK connected with USB
The maximum sampling rate I can get is 768kHz, which I measure by zooming in as much as possible and counting samples in a track in 0.1ms

I type in 768000 into the “Project Rate (Hz)” box in the lower left corner of the GUI.
I choose “Other” and type in 768000 to the box next to it in Edit>Preferences>Quality
The sample format is 32bit float.
In Audio Setup
Set Interface, Host to Windows WASAPI
Set record device to “Line (2- TI USB Audio UAC2.0)”
Set channels to 8

I think it took a few iterations of recording, and saving files and projects, before I actually got 768kHz, but now that I know what to do, it may
actually work the first time, but I would have to try it on a clean version of Windows (no prior installation of Audacity).

Multichannel recording is explained at