Unable to open project

Hi there, hopefully someone can help me. When I first recorded the project, I didn’t have enough space on my disk. Once I made space, it saved the file with no issue. When I opened the file and tried to edit it, it would not allow me to make any changes. I made more space and tried to re-open the project, but it just didn’t open anymore. I got the error:
Failed to open database file
“timestamp”: 1662199577,
“event_id”: “93fb6123f067334fb84e65a72e4867d1”,
“platform”: “native”,
“release”: “audacity@3.1.3”,
“contexts”: {
“os”: {
“type”: “os”,
“name”: “Windows”,
“version”: “10.0.19044”
“exception”: {
“values”: [
“type”: “Error_Opening_Project”,
“value”: “Failed to open database file:\n\n”,
“mechanism”: {
“type”: “runtime_error”,
“handled”: false,
“data”: {
“sqlite3.rc”: “8”,
“sqlite3.context”: “DBConnection::ModeConfig”,
“sqlite3.mode”: “PRAGMA .page_size = 65536;VACUUM;”,
“log”: “12:06:17: DBConnection SetDBError\n\tErrorCode: 8\n\tLastError: Failed to set page size for database \n\tLibraryError: attempt to write a readonly database\n12:06:17: DBConnection SetError\n\tErrorCode: 8\n\tLastError: Failed to open database file:\n\n\n\tLibraryError: (8): attempt to write a readonly database\n”
Screenshot 2022-09-03 120852.jpg

The above message, translates to “The SQLITE_READONLY result code is returned when an attempt is made to alter some data for which the current database connection does not have write permission.”

For some reason SQL (the underlying Audacity database engine) thinks it cannot write to the (.aup3) file. I do not know why this is. Perhaps the location is write protected or you do not have permission to write to the directory. Perhaps the file is networked in some fashion.

I try moving the .aup3 file to a different location (perhaps your desktop?). If the file will still not open from the other location, then continue with your corrupt file recovery attempts that you reported elsewhere, then report back.

I moved the file to a few other locations and it makes no difference. When I open the file I tried to repair with the instructions from the other post, this is what I am getting (see picture). I updated Audacity today so it can’t be outdated.
Screenshot 333333333333.jpg

Yes, and I can see from your other post here: https://forum.audacityteam.org/t/corrupt-or-otherwise-broken-audacity-project-recovery/64162/67

I have replied to your other thread, so I am locking this thread to avoid confusion.