Unable to open AUP3-project

Unable to open Audacity AUP3-project - “Failed to retrieve data from the project file.”
OS: Windows 10, version 1909
Audacity Version: 3.0.4


I’m unable to open an AUP3-project file. In previous versions of Audacity (3.0.2 and 3.0.3), I would get a different error message saying “Audacity failed to read from a file in H:”, but after upgrading to 3.0.4, it’s different. This time it reads: Failed to retrieve data from the project file. The following command failed: SELECT dict || doc FROM project WHERE id = 1;

    "timestamp": 1629983401,
    "event_id": "b7b2d6ae5ca7fd4b814b9ecdad66a3a2",
    "platform": "native",
    "release": "audacity@3.0.4",
    "contexts": {
        "os": {
            "type": "os",
            "name": "Windows",
            "version": "10.0.18363"
    "exception": {
        "values": [
                "type": "Error_Opening_Project",
                "value": "Failed to retrieve data from the project file.\nThe following command failed:\n\nSELECT dict || doc FROM project WHERE id = 1;",
                "mechanism": {
                    "type": "runtime_error",
                    "handled": false,
                    "data": {
                        "sqlite3.query": "SELECT dict || doc FROM project WHERE id = 1;",
                        "sqlite3.rc": "11",
                        "sqlite3.context": "ProjectGileIO::GetBlob::step",
                        "log": "15:10:01: FFmpeg libraries loaded successfully.\n15:10:01: sqlite3 message: (11) database corruption at line 69874 of [1b256d97b5]\n15:10:01: sqlite3 message: (11) statement aborts at 5: [SELECT dict || doc FROM project WHERE id = 1;] database disk image is malformed\n15:10:01: DBConnection SetDBError\n\tErrorCode: 11\n\tLastError: Failed to retrieve data from the project file.\nThe following command failed:\n\nSELECT dict || doc FROM project WHERE id = 1;\n\tLibraryError: database disk image is malformed\n"

Can someone please let me know if it’s possible to restore the project? Lmk if there’s any more information that’s needed!

Best regards

These are the worrying parts:

database corruption at line 69874 of [1b256d97b5]
database disk image is malformed

I’m not optimistic about recovery.

Were you working on the file on drive H: ?
What is “drive H:” ?

Did Audacity close cleanly when you closed the project, or did you cancel the “Compacting” window?

Hi Steve,

This project was corrupted a while back now, I don’t remember how it happened, just one day when I went to open it- it wouldn’t work anymore.

H: is a local drive on my computer.

Best regards

If you wish, zip up your .aup3 file and upload it to a public file server. Post a link or PM it to me. I’ll take a look at it.

H: is a local drive on my computer.

Your computer has five local disks? Cloud drives are configured for ease of use so they “appear” to be local drives, when in fact, they’re internet connected. Audacity doesn’t like that very much and it can cause data quality problems.

Is H: still there and working if you disconnect your network or WiFi? Disconnect from the internet and try to save something to H:.


Thanks Jade, same procedure as last time, I’ll upload it dropbox and send you the link. You’re the best!

Hi Koz,

Yep, five local drives (how did you know!?) and I’d get more if I could! :slight_smile:
H: is a Seagate Barracuda 3TB. There’s nothing wrong with it, it’s the AUP3 file that’s gone bad. It’s not the first time that this has happened to me.

Best regards

It’s not the first time that this has happened to me.

Any common threads? The shows all go over some time duration? They’re all heavy on Copy/Cut/Paste? They all have multiple layers/timelines?

Nobody has yet connected the dots of Wildly Renegade Envelope Control Points (WRECP’s) and anyone actually using the Envelope Tool. That’s not an accidental tool. Big blue lines show up on your timeline and concerned people have posted wondering what those were. What those may be is brushing the F2 key by accident as you’re typing.

Are you using the Envelope Tool?


how did you know!?

A: and B: are the two floppies (obviously), C: is the hard drive, D: is the CD/DVD drive or second hard drive, and additional drives go up from there. Doesn’t everybody do it that way?

It’s not unusual for Cloud Drives to automatically assume an available drive letter so to appear as normal and comfortable as possible. Otherwise, there’s just nothing quite like manually mounting a network service on a Windows machine. You go ahead. I’ll be back in a couple of hours.


Unfortunately I cannot remember why this project got corrupted. Unlike the first time this happened to me, I knew exactly what I did in order to produce it (more information available in this SC: https://forum.audacityteam.org/t/aup3-corrupted-project/62274/1). However, for this project, I just went to open it one day and it wouldn’t.

So far, I’ve had two projects fail on me. If I compare them, both are quite large (+2 GB), but other than that, I don’t think they’re that similar. Both of them do use a lot of tracks though. The first project has around 40 tracks (stereo and mono) (this is the one that Jade helped me to restore). As for the other project, I can’t verify as I cannot open it, but I think that there are 8-mono tracks. The total run-time for both projects are very much different. First project is at 4-minutes, other one I estimate at around 35-40 minutes. I do use Copy/Cut/Paste a lot.

I do use the Envelope Tool and I know for a fact that the first project that got corrupted (that Jade helped me to restore) uses it, as for this project- I am not sure.

Well, maybe not the best. :wink: I have bad news and bad news, which do you want to hear first? :frowning: So that little “11” buried in your error report is SQLite “geek” code for your file is corrupted. This is not an audacity problem - the problem is with the underlying SQLite database. Only half of the master “key” record is present, but more importantly, only 6 of thousands of data records are present. I have tried several programs that profess to “fix” corrupt SQLite data bases, but none of them give a whimper of a thought that the database is recoverable. I have exhausted the tools currently available to “recover” the database.

However, it turns out that I have a developed a program that can extract raw audio from your database. So I have been able to extract your “raw” audio. :slight_smile: There seems to be several good sections of audio in there. :slight_smile: Unfortunately, you are going to have to spend time with it to determine if you are able to make use of it. :frowning: You may find it easier to re-record. :wink:

I have PM’d you the link.

I understand… shame that you weren’t able to restore the project completely, but thank you for trying!

The audio that you did manage to recover is regrettably difficult to work with as it’s supposed to be spread across eight different tracks. As you said, probably easier to re-record. Still, I’m amazed that you were able to get any information out of it!

Last time that I had this issue I ran into error 101, so it’s different this time. Wonder if Audacity somehow crashed, or if I accidentally closed it during the “compacting project”-phase. At any rate, here’s hoping that I won’t have to open another thread with another corrupted project :smiley: