Unable to locate the lame

Hi Audacity Team,
I am using Audacity new version 3.5.1

I am trying to export a file with the format “(external program)” and adding a file name extension “.m4a” at the end with this command
"ffmpeg -i - -movflags +faststart “%f”

it was working fine until I was using 3.3 version(I think…!!), however after updating the audacity, now it says “unable to locate the lame”.

upon searching the Internet there were a few techniques that said “locate it manually”, however I don’t see the option in the recent version. can you please help? i would really appreciate it. thanks so much

Nauman


The double quote before the %f is not a normal double-quote character. It should be:

ffmpeg -i - -movflags +faststart "%f"

I’ve never used the “external program” option but LAME is MP3, not M4A.

Audacity is confused, or maybe FFmpeg is confused.

thanks for the response, Steve. you are write. but that seems to be a typo mistake on my end while writing that code here. in my audacity, its the same as you wrote. i even copied your code, but it still gives me the same warning/issue.

The corrected version works for me (on Linux).

What happens if you tick the “show output” option?

by clicking/ticking (:heavy_check_mark:) the show output option, it still gives the same issue.

do you recommend I get back to previous years version of the audacity?

Please post the full contents of the output with your reply.

It seems that the inclusion of LAME in the recent version of Audacity by default is creating problems.

I think going back to the previous version of Audacity will be better in this case. what you think?