Unable to Install FFmpeg on macOS Catalina

Hello. I don’t know if this is something I’m doing wrong, but no matter what I do or how I try to install FFmpeg for use with Audacity, it does not work. I’m using macOS Catalina 10.15.7.
I have tried the .pkg installer thing from https://lame.buanzo.org/ffmpeg.php and the static binary from static FFmpeg binaries for macOS 64-bit but neither of these have worked. The app continuously claims it doesn’t recognise “libavformat.dylib” when IT’S RIGHT THERE in the default folder.

As seen in this screenshot, (new user limitations) libavformat.59.16.100.dylib is in fact present. I even tried removing the numbers from the end but still it wouldn’t recognise the damn thing. The preferences page keeps instantly reverting to FFmpeg Library Version: FFmpeg library not found no matter what I do. The presence of the files should mean I already installed it successfully but it still won’t open .m4a files. Don’t try to get me to use this Homebrew thing because I don’t understand how it works. If this is something wrong with the app I’d greatly appreciate if it gets fixed, and if someone publishes it under a title including “so it actually works”.