Unable to install ERA-R VST plug-in

I’ve been having the same issue. Tried to install ERA-R but when I enable and confirm is reverts back to he “new” state and doesn’t show up in the list. I’ve tried both 64 and 32bit and all the folders. Reinstalled both the plugin and audacity itself.

Using windows 10 and audacity 2.2.1

Audacity’s VST support is limited. Some VST plug-ins that are NOT supported are:

  • 64-bit VST plug-ins, (they have to be 32-bit).
  • “protected” plug-ins that have not been “activated” (see the plug-in documentation).
  • iLok, or most other plug-in verification “protections” (anti-piracy protections).
  • pirated plug-ins.
  • VST Instruments (VSTi).
  • MIDI plug-ins, or MIDI features in audio plug-ins.

Many free 32-bit VST audio effects work, and some commercial 32-bit VST audio effects, though plug-in verification protection will often prevent commercial VSTs from working.

Their verification window never popped up but I figured that was due to the plugin never actually opening. I’m going to try to downgrade to 2.1.2 as the site said it was compatible with that version specifally. Thank you for the information though. I guess I’ll update if it works.

Let us know how you get on, and good luck.