Unable to import .wav and .ogg

Whenever I attempt to import .wav or .ogg, it gives me the following error:

"Audacity did not recognize the type of the file “filename.wav” (or “filename.ogg”). If it is uncompressed, try importing it using “import raw”. "

When I did that, it was just a loud burst of static and noise.

How can I fix this? Thanks!

Ensure that you have Audacity 2.1.0 from here: http://web.audacityteam.org/download/windows

If you are using that version, try resetting the Audacity preferences by re-installing and selecting the option to “reset preferences” during the installation. On first launch after reinstalling, you will be asked to confirm that you wish to reset preferences.

Sorry it took me so long to reply; got distracted with other things.
I tried what you said, and it didn’t work. However, weird thing is, if I import it as an .mp3, then export it was .wav, then import that .wav, THAT .wav works; however, if I download it as .wav (from the same way I download as .mp3) and attempt to import it, it gives me this error.

Seems that your downloaded WAV file is either corrupt, or it is not really a WAV file.

Since you’re on Windows, your file could be named MyFile.wav.mp4, and Windows would hide the .mp4 (MPEG-4)part.

You can get windows to show you the complete filenames rather than try to hide them.

Hidden File Extensions - Windows
– Start > My Computer > Tools > Folder Options > View > [ ] Hide Extensions for Known File Types (deselect)
– Apply (to this folder) or Apply to All Folders
– OK


Also you can download “MediaInfo” from http://mediainfo.sourceforge.net/en/Download/Windows to find out what type of file you really have. Get the version without installer, because the installer may have malware or adware.


No, I did that, and they’re still .wav and .ogg, no extra file extensions after that. I don’t know why audacity doesn’t like the file, but likes its own export.

I’ll just try and explain what I’m doing. I’m trying to speed up and slow down audios. When I download an .mp3 file and speed it up, then slow it down later, it sounds muffled, since the file is compressed. However, when I use .wav and .ogg, those aren’t compressed audio file types, so they don’t sound muffled when slowed down or sped up.
Yesterday, when I downloaded it as .mp3, I took that .mp3, and instantly used audacity to export it as a .wav right after, and when I slowed the new .wav down, it wasn’t muffled.
However, when I did the same thing today, it still sounded muffled… does the length of the audio effect that? I’m pretty sure .wav and .ogg shouldn’t sound muffled despite that.

OGG is compressed, and slightly lossy. WAV is uncompressed and lossless.

Audacity does not open MP3 files. When it Imports an MP3, it “expands” it to PCM (similar to WAV) but that merely prevents the file’s quality getting worse. It does not improve it.

So, exporting the originally imported (now PCM) audio as WAV and reimporting the WAV does not improve it, either.

I think you are hearing subtle things that may or may not be real. However if you want to change tempo (without changing pitch) in the highest quality way, use Sliding Time Scale / Pitch Shift.


I repeat my suggestion that you could examine the file in MediaInfo which can tell you what type of audio it actually contains.