Unable to import mp4


I’m recording mp4 using OBS Multiplatform, then attempting to import / extract two recorded audio tracks into Audacity. I have FFmpeg installed ( F(55.33.100),C(55.102.22),U(52.66.100) ).

Initially on Import > Audio I’d get an error stating that the file was in Advanced Audio Codec format and couldn’t be opened unless it was in WAV or AIFF format. I changed the order of import filters and the error message went away, but any mp4 now loads as a string of garbled electronic noise.

Copied from the log:

6:54:29 PM: Audacity 2.1.1
6:54:29 PM: Trying to load FFmpeg libraries...
6:54:29 PM: Trying to load FFmpeg libraries from default path, 'C:\Program Files (x86)\FFmpeg for Audacity\avformat-55.dll'.
6:54:29 PM: Looking up PATH environment variable...
6:54:29 PM: PATH = 'C:\Program Files\Common Files\Microsoft Shared\Windows Live;C:\Program Files (x86)\Common Files\Microsoft Shared\Windows Live;C:\ProgramData\Oracle\Java\javapath;C:\Program Files (x86)\Intel\iCLS Client\;C:\Program Files\Intel\iCLS Client\;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;c:\Program Files (x86)\Microsoft SQL Server\100\Tools\Binn\;c:\Program Files (x86)\Microsoft SQL Server\100\DTS\Binn\;C:\Program Files (x86)\Java\jre7\bin;C:\Program Files\Intel\Intel(R) Management Engine Components\DAL;C:\Program Files (x86)\Intel\Intel(R) Management Engine Components\DAL;C:\Program Files\Intel\Intel(R) Management Engine Components\IPT;C:\Program Files (x86)\Intel\Intel(R) Management Engine Components\IPT;C:\Program Files (x86)\NVIDIA Corporation\PhysX\Common;C:\Program Files (x86)\Windows Live\Shared;C:\Program Files (x86)\Jahshaka\..\gtk2\bin;C:\Program Files (x86)\Jahshaka\..\mlt\bin;C:\Program Files (x86)\OpenLibraries\bin;C:\Program Files (x86)\Skype\Phone\'
6:54:29 PM: Checking that 'C:\Program Files (x86)\FFmpeg for Audacity' is in PATH...
6:54:29 PM: Warning: FFmpeg directory 'C:\Program Files (x86)\FFmpeg for Audacity' is not in PATH.
6:54:29 PM: Temporarily prepending ';C:\Program Files (x86)\FFmpeg for Audacity' to PATH...
6:54:29 PM: Checking for monolithic avformat from 'C:\Program Files (x86)\FFmpeg for Audacity\avformat-55.dll'.
6:54:29 PM: Error: Couldn't find symbol 'avutil_version' in a dynamic library (error 127: the specified procedure could not be found.)
6:54:29 PM: Error: Couldn't find symbol 'avcodec_version' in a dynamic library (error 127: the specified procedure could not be found.)
6:54:29 PM: avformat not monolithic
6:54:29 PM: Loading avutil from 'avutil-52.dll'.
6:54:29 PM: Loading avcodec from 'avcodec-55.dll'.
6:54:29 PM: Loading avformat from 'C:\Program Files (x86)\FFmpeg for Audacity\avformat-55.dll'.
6:54:29 PM: Returning PATH to previous setting...
6:54:29 PM: Actual avutil path C:\Program Files (x86)\FFmpeg for Audacity\avutil-52.dll
6:54:29 PM: Actual avcodec path C:\Program Files (x86)\FFmpeg for Audacity\avcodec-55.dll
6:54:29 PM: Actual avformat path C:\Program Files (x86)\FFmpeg for Audacity\avformat-55.dll
6:54:29 PM: Importing symbols...
6:54:29 PM: All symbols loaded successfully. Initializing the library.
6:54:29 PM: Retrieving FFmpeg library version numbers:
6:54:29 PM:    AVCodec version 0x373466 - 55.52.102 (built against 0x373466 - 55.52.102)
6:54:29 PM:    AVFormat version 0x372164 - 55.33.100 (built against 0x372164 - 55.33.100)
6:54:29 PM:    AVUtil version 0x344264 - 52.66.100 (built against 0x344264 - 52.66.100)
6:54:29 PM: FFmpeg libraries loaded successfully.
6:54:40 PM: File name is C:\Users\Burke\Videos\2015-09-21 18-53-29.mp4
6:54:40 PM: Mime type is *
6:54:40 PM: Opening with libav
6:54:40 PM: Open(C:\Users\Burke\Videos\2015-09-21 18-53-29.mp4) succeeded
6:54:42 PM: Opening with libsndfile
6:54:42 PM: Opening with liboggvorbis
6:54:42 PM: Opening with libflac
6:54:42 PM: Opening with lof
6:54:42 PM: Error: Importer::Import: Opening failed.

Please help me find and correct the error.

I believe FFMpeg should be able to open an AAC file.

Open Audacity preferences > Libraries and see if it “knows” where FFMpeg is. If it offers to go looking for it, then maybe you didn’t install it right.


Which version of Windows are you on?

Did you install this version of FFmpeg: http://manual.audacityteam.org/o/man/faq_installation_and_plug_ins.html#ffdown

To what?

Is it just one particular file that has the problem?

MP4 is a container format. The required codecs depend on what the MP4 file contains. Where did the file that you are having problems with come from? Does the file play correctly in other applications?

Note that Audacity does not support DRM.

(FFmpeg has many options that may be enabled or not at the time when the FFmpeg dll’s are created from the source code. I’m not on Windows, but as far as I’m aware, M4A decoding is enabled in that version.)

Conflicting ffmpeg versions? OBS also uses ffmpeg for import/export…

FFmpeg default build options enable AAC playback - the playback support is native, that is, it doesn’t depend on any external libraries.

The recommended FFmpeg 2.2.2 for Windows does have AAC decoding enabled. That assumes an MP4 file contains AAC audio, as Steve says.

There is no need to change the importer order in Extended Import Preferences. FFmpeg will always be tried. On Windows, for an M4A file containing the usual AAC audio, FFmpeg is the only importer that would succeed in importing the file.

If it’s not too large a video and you can upload it somewhere, please do so, so we can examine it.

Otherwise I would suggest examining the file in “MediaInfo” from http://mediainfo.sourceforge.net/en/Download/Windows. Post what MediaInfo says about the file (change the View option to “Text”).

Get the MediaInfo version without installer, because the installer may have malware or adware.


Thanks for all the responses.

I went through everyone’s suggestions, and when Steve asked if I’d downloaded the correct version of FFmpeg (I had), I decided to re-download and re-install it just to make sure.

That seems to have fixed the issue. I’ve successfully imported MP4 audio in single tracks from four different files.

I believe the issue was in the installation, OR in the fact that I was attempting to import two tracks at once. Either way, it’s fixed. Thanks again!

If you import multiple files, the subsequent files are queued. So that should not be a problem.

Have you tried that same specific video again (C:\Users\Burke\Videos\2015-09-21 18-53-29.mp4) ? It is more “likely” to be a problem with that file.