Unable to import large (500MB) WAV files

I’ve recorded two 500MB WAV files (left and right channels) - a band rehearsal. I want to import both channels into Audacity to snip the tracks up into individual songs and snip out chatter from between songs. I can’t get either track to import - I’ve waited 20-30 minutes with Audacity churning away (based on ps, there’s no visible indication in the interface to suggest it’s doing anything). I’ve tried “import” and selected in situ (not copying the file) to achieve faster import as well as the copy approach. I’ve also tried “open” which seemed to lead through the same process. My Audacity version is 2.0.5 running on Linux Mint 17.2.

The details of the track (the other is the same, but the other channel) from mediainfo:

Complete name : TEX000_1.WAV
Format : Wave
File size : 550 MiB
Duration : 1h 48mn
Overall bit rate mode : Constant
Overall bit rate : 706 Kbps

Format : PCM
Format settings, Endianness : Little
Format settings, Sign : Signed
Codec ID : 1
Duration : 1h 48mn
Bit rate mode : Constant
Bit rate : 705.6 Kbps
Channel(s) : 1 channel
Sampling rate : 44.1 KHz
Bit depth : 16 bits
Stream size : 550 MiB (100%)

I’ve got 3GB of free space available on the local drive.

Any ideas why I can’t seem to import this file? Is it just a matter of time? Should Audacity be providing some visible indicator that it’s “importing” the file? Thanks.

I’ve got 3GB of free space available on the local drive.

I go not enough. 30GB maybe, not 3. Audacity imports sound files in a very high quality internal format. It’s not 500MB any more, it’s quite a bit larger, and the first time you perform effects, the internal size doubles and triples.

30GB. Or better.


Are you sure - this is already lossless, does Audacity store it at greater than WAV resolution?! For what it’s worth, when I told the importer to use the WAV files in-situ rather than copying them, it chugged away for a long time, but didn’t seem to use additional disk space.

By default, Audacity works with “32-bit float PCM” format, (double the disk space of a “normal” 16-bit WAV file, but virtually perfect processing precision).
By default, Audacity maintains an “Undo History” until you close the project (the Undo history is not saved when you save the project). The Undo history keeps a copy of previous “states” in the same very high quality 32-bit float format. This means that projects grow rapidly in size as you work on them.

An important detail :wink:

“On demand” importing uses very little disk space until you start working on the recording. Audacity will access the file directly rather than copying it into the project and will only copy the data when you make changes to the audio. Of course this means that the original WAV file needs to be available to Audacity until you finish the project, otherwise Audacity will not be able to read the audio data.

Did you not even see the “stripy” waveform?

Does the file play correctly in other applications?

I can play the mono tracks in VLC individually without issue.

And, no, I don’t get any track information showing in the interface - no visible indication of progress in the Audacity interface at all.

Tried importing one track again, this time shifting the Audacity tmp/working directory to the external (USB) drive also holding the WAV files (200GB free space)… Same behaviour - big CPU hit and disk activity (but not much writing to disk), no visible progress in interface, but steadily mounting memory use… killed it after 20min.

Where did Audacity 2.0.5 come from? Is it the packaged build offered by Linux Mint? We’ve seen Linux Mint’s Audacity fail to import files (nothing happens) before. They were MP3 files in that case.

You can try quitting Audacity and open ~/.audacity-data/audacity.cfg in your favourite text editor. Delete all the content then at the top, add this line only:


Save the file and restart Audacity.

If that does not help, uninstall 2.0.5 and try installing the 2.1.1 PPA for Ubuntu Trusty (the base Ubuntu version Linux Mint 17 is built on) from https://launchpad.net/~ubuntuhandbook1/+archive/ubuntu/audacity.

Read http://ubuntuhandbook.org/index.php/2015/04/install-audacity-audio-editor-2-1-0-in-ubuntu-from-ppa/ for how to install the PPA.


Many thanks Gale, will give both a try (happy with installing from PPAs :slight_smile:) and report back.

Ok, tried scrubbing my cfg file and upgrading to 2.1.1 via the PPA… no change in behaviour - in fact Audacity crashes after churning for 10 min, still no visible feedback through interface - I just watch the virtual RAM increasing (no appreciable change to disk space)… sigh

Did you uninstall 2.0.5 first?

The problem could be in some library that Linux Mint provide. Are you on a 64-bit or 32-bit computer?

A solution to a library problem might be to compile Audacity yourself from the full source tarball, configuring wherever possible with local rather than system libraries.

Just as a point of reference, if you Generate > Tone of 1 hour, export as WAV (Microsoft) 16-bit PCM, then import the WAV, what happens?