Unable to Get Audacity to Record [SOLVED]

I’m new; just joined this morning. I am using Windows 7 PRO 64bit; along with Audacity version 2.1.2,
installed from the .exe version. When I click on the record button, down at the bottom of the Audacity screen,
it says recording. But nothing’s happening. At the bottom where it says selection start, no numbers are moving.

And on the two channels, there is no activity; nothing’s moving at all. I tried the FAQ’s; I tried several settings.
No success. In the past, when I had Audacity on earlier computers, whenever I opened Audacity, I would get two
channels ready to go. When I clicked the record button, it would start recording okay. Now, when I open Audacity,
I don’t see any channels visible.

When I now click the record button, two channels would appear; but I don’t see any activity at all!
I hope I put sufficient information here. Can anyone help? Thanks in advance!

What exactly are you recording, using what recording device? Use Device Toolbar to select the recording device you are using. Try MME host in the first box of Device Toolbar.

Turn off Transport > Sound Activated Recording.

Make sure Edit > Preferences… > Recording, “Audio to buffer” is set high enough (at least the default 100 milliseconds). It might need to be set higher.

If the recording is still stalled, try rebooting the computer, especially if it’s a USB recording device.


Gale Andrews, thanks for your prompt reply! I knew I forgot something.
I attempted to do a test recording from an audio CD, in the DVD drive.
The device used, is the Audio Host Windows Wasapi. The MME & the other
option is not recognized.

The Transport Sound Activated Recording is turned off.
The Audio to Buffer is set at the default of 100 milliseconds. I will try a reboot.

What do you want to record under normal circumstances? You can rip CD’s to WAV files.

If you normally want to record computer playback, see Tutorial - Recording Computer Playback on Windows.

With WASAPI loopback recording of computer playback, the audio stream must be playing before you record, at least the first time.


Hey G.A. I got it! I just found some info referring to the Wasapi device!
On the Device Toolbar for the recording device, I had to select “Speakers (Realtek High Definition Audio) loopback”.
Previously, I selected “Realtek Digital Output (Realtek High Definition Audio) loopback,” as the recording device.

I guess I was trying to think too much like Mr. Spock! Logically, why would I select something saying Speakers,
when I want to record?! But obviously, with this Wasapi configuration, that’s how it works!
Anyway, selecting the Speakers thingie for the recording device did the job!
Now, it’s working beautifully! Thanks so much for taking the time to help.

Very much appreciated, it was!