Ubuntu 19.10 arm64 on Raspberry Pi 4 now Gentoo too

Looking to find the limits of the latest RPi I decided to have a go at compiling Audacity. I am running on the 64 bit version of Ubuntu with the KDE desktop and it was generally reponsive enough to be worth a try. First I just used the standard source and tried to follow …/linux/config.txt .
This is OK up to a point and I got through the wxwidgets install and compile but for the very last install step which seems to be missing.

At this point I changed to Steve’s recent how to post and downloaded the audacity source from foss hub as he recommends. This went OK until the config script fell over with the message that a version of gcc which supported -msse was needed. It seem that the config.guess script returns a build type of aarch64-unknow-linux-gnu and although I tried to replace unknown with one or two of my own guesses by using the --build= option for config I couldn’t come up with anything that worked. Then I found this post
which reports a similar problem and suggests that --disable-sse could work and sure enough it did the trick. I was then able to build and install Audacity.

I haven’t tested it extensively but it seems very responsive and OK for general use. It loads in under 30 seconds. I am using a USB external audio interface ( RME Babyface) taking advantage of the PI 4 USB 3 sockets which provide plenty of power for it. There does seem to be a playback problem for project sample rates over 96KHz even though playing 192KHz files with this setting still works OK. I know nothing about the ALSA interface in Linux so as the CPU doesn’t seem to be overloaded there may be some improvements to be made by someone who knows what they are doing!

Finally I can’t resist commenting that the wxWidgets graphics on Ubuntu look much smarter than they do on windows. Gives an air of professionalism to Audacity.

I’ve now used the Gentoo arm64 version and also configured so that the root file system is on a 64GB solid state disk running via USB 3 adapter. The Pi is booting from a small SD card but once booted all the active files ( including the Audacity temporary file area ) are running on the USB/Sata drive. Compiling Audacity only threw up one error regarding lack of SSE and was fixed exactly as my original Ubuntu post above. The Gentoo image already had all prerequisites except wxWidgets installed, and the wxWidgets GTK version compiled and linked without any problems. The whole installation process took more than 3 hours and gave the Pi a good workout. I have a passive aluminium cooling sandwich which got pretty hot but not burning hot.

Performance is better than the Ubuntu version but this may all be because of the faster disk arrangement. So far I’ve played 192KHz files easily enough but haven’t done any further testing yet. I am also trying out a 4K monitor but this is unreliable and does no favours for the Audacity/wx interface so I’ll probably drop back to a more conservative screen resolution. I will also be testing an external usb audio device ( RME) and trying some ambitious high quality recording.

Interesting experiments.
Do you have a practical purpose in mind? (a portable multi-track recorder?)

Have you tried using Jack? I’ve read that Jack can be used on the Pi, though I’ve never tried it myself.