Ubuntu 18.04.3 USB mic (OSS) has no supported sample rates


thanks for Audacity. It is great.
However I bought a new USB mic (Apogee Mic Plus) to connect to my desktop (running Ubuntu 18.04.3 on SSD and Audacity 2.3.2).
I cannot get it to work correctly. In Ubuntu->Sound I can see and hear my mic.
In Audacity I can select the mic (/dev/dsp), but when trying to record, it tells me “error -9997 Invalid sample rate”.

When I run Audacity->Help->Diagnostics->Audio device info, I get multiple SALSA devices (which I used up till now) and my one OSS device (Mic with headphone connection):

Device ID: 13
Device name: /dev/dsp
Host name: OSS
Recording channels: 16
Playback channels: 16
Low Recording Latency: 0.00870748
Low Playback Latency: 0.00870748
High Recording Latency: 0.0348299
High Playback Latency: 0.0348299
Supported Rates:

I think the problem is that no sample rates are supported. Can I change this / add sample rates? If so, where and how?
If not, is there a work-around or do I have to switch to Windows?

Thanks for your input!

Audacity retrieves the list of sample rates from the device drivers. If no sample rates are listed, then that does not necessarily mean that no sample rates are supported, it just means that the device driver does not say what sample rates are supported.

Please save that info (click the “Save” or “OK” button to save the info as a file), then attach the file to your reply so that we can see the full info.
See here for how to attach a file to a forum post: https://forum.audacityteam.org/t/how-to-attach-files-to-forum-posts/24026/1

Hi Steve,

thanks for your reply. This is very hopeful.
I attached the full Device info.

deviceinfo.txt (4.87 KB)

Do you know why your USB mic is using OSS rather than ALSA? OSS is generally considered obsolete, or at best “legacy”.

I have absolutely no idea. I know OSS is legacy, but does Apogee know that too :wink:

Did you install drivers from Apogee? It’s rare for hardware manufacturers to provide drivers for Linux.

I installed no drivers what so ever.

I thought I do an uninstall/ install and noticed there are 2 versions of Audacity in my Software Centre. Both with different outcomes:

First I uninstalled my version, then installed:
A) version 2.3.2 (Developer: Daniel Llewellyn)
Size: 82Mb
Source: Snap Store
When I installed this, all my devices were gone except the defaults. Only one ALSA, no OSS.

Of course, I uninstalled this one and installed:
B) version: 2.3.3-0build1~ubuntu18.04 (26/11/2019)
Size 4.2 Mb
Source: lp_ppa_ubuntuhandbook1_audacity-bionic-main
Return of all my 14 devices incl OSS. However, no supported sample rates…

Hi Steve,
some additional info:
I installed Audio Recorder (UNOFFICIAL) from Ubuntu Software and it can use the Mic without problems…

What happens with Audacity 2.2.1 from the main Ubuntu repository?

There is no 2.2.1 in my repository.
On the web I found: https://www.audacityteam.org/audacity-2-2-1-released-2/
But no download…

A quick install of 2.3.3 on a Windows 10 laptop resulted in a flawless recording & playback.
I can use the laptop for now, but I really like Ubuntu better…

You need to uninstall your current version of Audacity, then disable or remove the PPA from your sources. Audacity 2.2.1 will then be available from the main Ubuntu repository.

No change. And the device info is the same (see attachment).
deviceinfo2.2.1.txt (4.94 KB)

Try changing the default sample rate in “Edit menu > Preferences > Quality”, then restart Audacity and try a test recording in a new, empty project.
Try sample rates of:

I don’t know if this will help, but it’s worth trying.

No, that doesn(t work either. I already tried it, and tried it again after the last install.
I noticed the LED on the mic was flashing when starting Audacity, to end in the “no operation” state (LED is blue).
When the mic can be used, the LED will stay on (green).

That’s interesting. It appears that the mic has built-in software (“firmware”) rather than just being a microphone with a class compliant USB audio chip.

I don’t see that in the Ubuntu repository. What does that say in “Help > About”?

There is no Help (or any kind of menu).
However in Ubuntu Software they give this link

With the mic connected, and Audacity NOT running:

In a Terminal window, enter:


then press the F6 key.

What “sound cards” are listed in the blue box?

Blue box states:

—Sound Card—

  • (default)
    0 HDA Intel PCH
    1 HDA Nvidia
    2 MiC Plus
    enter device name

Number 2 is the mic I try to use.

Additional: if I select MiC Plus

Card: MiC Plus
Chip: USB Mixer

I can adjust Playback & Capture, but the LED on the mic stays blue (idle).