Turning off looping after clearing loop region?

Hello! I’m currently using 3.1.3 and getting used to the new features. Looping shows promise on being useful but there is one aspect I’ve found a bit clunky.

After selecting a loop region, and then using “Clear looping region” (either from right-clicking on the time line or using the hotkey), it indeed clears the looping region, but does not turn off Looping.

What happens then is that I highlight a region to play only that, and it just keeps playing beyond the selection instead of stopping at the end of the highlighted region.

There is the “Loop on/off” icon at the top-left which stays toggled, but it is not very obvious in the interface especially when you just operate the software exclusively with hotkeys.

What then needs to be done is manually turn off looping, and then selections play properly.

But if there is no current looping region active, it kinda doesn’t make sense to keep “Looping” turned on. I think it would be more intuitive if “Clearing loop region” also turned off “Loop”. Then looping will be turned back on when the user defines a new looping region.

Thanks for considering it!

I agree that it’s clunky, but if you just want to turn off looping, there’s no need to clear the looping selection - just turn off looping (shortcut: “L”).

Hello! Thanks for your reply.

I did think of that, but if I just turn off looping, then the next time I want to define a loop region I will highlight it, press L, and it will instead just re-enable the loop for my previous looping region.

If I’m done editing a region on loop, I would prefer to just forget about it (by clearing it), and when I find another region I want to loop it just feels nice to be able to define a new region by only pressing “L”.

It might just be how my brain works specifically and/or too nitpicky, but it just personally feels like a nicer workflow and thought I would bring it up as a suggestion anyway in case you agreed :slight_smile:

If you don’t think that’s worth implementing that’s ok and I will just get used to how it is now :slight_smile:

Alternatively, if pressing L without a selection just toggles looping, but pressing L with a selection defines a looping region, that would work nicely too.

Also I just found I can define a shortcut for “Set loop to selection” so maybe I can find a way to work with that.

Previously it was a much more efficient workflow. No buttons, no special “loop modes”, just make a selection and “Shift + Space” to loop play. The new development team “improved” it so now it is as it is.

Hi–I’m an author narrating her own book and I have limited knowledge of audacity. I accidentally dragged my mouse and created a loop! Now I don’t know how to undo this because I didn’t realize I had created the loop until I played back the entire chapter. If I highlight the looped part, what should I click to un-loop? Someone please save me and use small words, please. TIA.

Just ensure that the “Loop button” is not pressed, and the loop region won’t do anything.
(Loop button: https://manual.audacityteam.org/man/transport_toolbar.html)