Trying to use the ESI U22 XT audio interface [SOLVED]

Hi folks,

I recently purchased the ESI U22 XT audio interface because I had heard that it works well with ALSA.

I’ve made various attempts to get Audacity to use this interface, but so far no luck. I’ve also tried the ALSA program ‘arecord’ but without success.

OS: Ubuntu 20.04.2 LTS

cat /proc/asound/cards
0 [PCH ]: HDA-Intel - HDA Intel PCH
HDA Intel PCH at 0xf7f10000 irq 44
1 [USB ]: USB-Audio - U22 XT USB
ESI Audiotechnik GmbH U22 XT USB at usb-0000:05:00.0-1, full speed
HDA ATI HDMI at 0xf7e60000 irq 45

Let me know what other info I can provide that would be helpful.

Any advice would be greatly appreciated. Tim

That’s a bad sign. If arecord doesn’t work then it’s unlikely that any other recording apps will.

What command did you use with ‘arecord’?
What happens when you use the command?

What do you get from these two commands:

aplay -l

arecord -l

(In both of the above two commands, the final character is lower case “L”)

Hi Steve, thanks so much for the quick reply and advice.

I contacted ESI and they gave me a quick reply which solved the problem. It turns out that there are inputs on the back of the device, not just the front, and a button to choose which inputs are active.

It did not occur to me that there would be inputs on the back, and as soon as I changed it to use the front inputs it started working.

So, that was a real easy fix, and a bit embarrassing, but I guess I’m not the first person to run into that since there is a knowledge base article about it.


Super :slight_smile:
Thanks for the update.