Trying to do a multitrack recording

Is there an option in Audacity 2.0.3 to “Play other tracks while recording new one”?

I don’t want to overdub. I want to hear my guitar track as I sing on the next track?

Any help greatly appreciated.

Multi-Track - Overdubbing always creates a new track. The value of Overdubbing is the ability to change or filter one instrument independently of all the others.


Thanks for your help but can I have a guitar track and seperately, a vocal track on Audacity. All I’m wanting to do is lay down a guitar track then listen to it on headphones as I lay down a vocal track?

can I have a guitar track and seperately, a vocal track on Audacity.

Yes. Two separate tracks one above the other. The one under those two is the violin track and the one underneath all those can be the Hammond Organ. Each one can be muted or soloed as you wish and each one can be filtered or have effects added independently of all the others. They all play at once (unless muted) so you can listen to what the final mix is going to sound like when you get done.

Unless you stop it, Audacity will try to mix the show down to one single stereo track when you Export.

If you need to stop what you’re doing and go to work or go to bed, you can Save an Audacity Project which will keep everything exactly in place except UNDO. If you need the UNDO, then you can’t turn the computer off or stop Audacity.


Sorry I still don’t get this!

I record a guitar on the first track.

I then listen to the guitar track in my headphones while recording a vocal track on the next track.

I now have a guitar track on track 1 and track two is guitar and vocals because it overdubs.

How do I hear just the vocal track on track two?

Check your settings in the Device Toolbar.
You do NOT want “Stereo Mix” or “Sound Mapper” as the recording input. You need to select the actual input that you are using as the recording input device (for example “Line In”).

My only two options are ‘external microphone’ and ‘sound mapper’.

I’ve got it set at ‘external microphone’ as I’m recording into the 3.5mm microphone jack of the laptop from a mixer.

Still, Audacity is recording “everything the computer is doing” instead of just your microphone.

Audacity > Edit > Devices > Recording > Device. That’s one place and also:
Windows > Control Panel > Audio or Sound. I’m not on a Windows machine. You should check both places. Windows should give you the ability to select the Microphone.

Which Windows do you have?


I’ve now looked under edit-devices-recording in Audacity and it’s set to external microphone.

Also in my control panel (Windows 7) the recording of sound is set as external microphone.

Are you wearing headphones? I think all the versions of the wiki are clear that you can only do overdubbing with headphones. Koz

Yes wearing headphones. Overdubbing isn’t the problem, it’s overdubbing okay. My problem is I don’t want it to!

I’m just trying to get a guitar track and a separate vocal track but it seems to me you have to have the 2nd track overdubbing the first. I’d have thought it would be a basic function of any recording multi track software that it is possible to have each instrument and each vocal on it’s own track for future mixing?

You can tell by our blank looks we have no idea why your computer is doing this. The desirable method of “overdubbing” you write, with separate tracks, is the way this normally works. It works that way on multiple different machines that I have a goodness knows how many machines around Earth.

Are you sure you turned off playthrough?

Audacity > Edit > Preferences > Recording > [_]Playthrough (de-select).


Try this. Set up for overdubbing, unplug your mixer from the soundcard, and press record anyway. Do you still get the old track recorded fresh on the new track?

Are they in sync? If you listen to both of them at once, is there a slight echo between them? Do they sound a little concert-hally in your headphones? Or are they plain, flat-sounding and identical.

This is going to take sitting in a corner for a minute. Where could the sound pathway come from to do that? That’s most unusual.

I’ve got it set at ‘external microphone’ as I’m recording into the 3.5mm microphone jack of the laptop from a mixer.

Where are the headphones plugged in? Where does the Headphone-Out of the laptop go, if anywhere?


Which mixer?


I’m making some progress! I was recording out of aux out and listening through aux in. I think I’m creating a loop!

Here’s the mixer…

I’m now trying to record out from the main mix but listen via aux in. I’m getting separate tracks but if I record a track 2 while listening to track 1 on the headphones, I can’t hear myself in the headphones live as I record track 2.

It’s driving me nuts! I’m trying to find out what leads and in/outs to use so I can multitrack record hearing everything on headphones. Any help appreciated!

Thank you.

This works one of two ways:

– You’re using one of the three hardware methods mentioned in the wiki article (all USB). There are a few more devices we found that work as well.

– You have a mixer that can produce two totally independent mixes of multiple inputs.

It works less well if you monitor the Headphone Out of the computer. In that case you almost always have echo or delay in the live feed and you can’t stop it. It drives most performers nuts.

So you’re going down the mixer route.

You need a mixer that has pre-fade Effects Send, Pre-Fade Mix, Studio Mix or a way to mix a separate show that has nothing to do with the real show going to the computer.

The microphones, instruments, players, and the computer playback all go into separate, independent input channels of the mixer. Mix down the show exactly as you want it to appear to the audience and send that – usually the mixer Line-Out or Tape-Out – to the computer for recording.

Leave the Computer Playback faders pulled down so that channel doesn’t mix into the show.

Using the pre-fade Effects Send knobs, mix a Second Show this time including the computer playback and send this to your headphones. This might mean you have to send the “Effects Out” of the mixer to a headphone amplifier to make it loud enough to hear. It’s possible, but not likely you can get this feed into the mixer’s headphone system. Most mixer don’t allow that.

This allows you to sing in perfect time into both the computer and your headphones and to listen to the computer existing tracks as part of the mix without feedback or double recording.

Another sillier way to do this is two mixers. The second mixer is for headphones and only has two inputs: The main mixer show and the computer playback.

The main mixer mixes the show or the new tracks and nothing else.

My mixer won’t work because my Effects Send for each channel is Post Fade. Once I pull the channel faders down (or turn them off), that’s the end of the special headphone feed. See illustration red knobs.

Screen shot 2013-05-08 at 5.19.20 PM.png

Is your AUX Send pre-fade or post-fade? If it’s pre, then that’s how you prepare the headphone mix. If it’s post, you’re in the same boat I am.

I think you’re in luck. The Top yellow knob in each channel, AUX Send, appears to be pre-fade. So connect all your inputs to the mixer as if they were real sources for the show including the computer. Mix the show going back to the computer normally but leave the computer channel turned down.

Bring up the AUX Sends on everything you want to listen to at once, this time including the computer. Listen to the AUX Send 1 connection. If it’s not loud enough and you run out of yellow knob range, then you’ll have to amplify it with an external headphone amplifier.


It’s possible your mixer allows headphone switching between Main and AUX. I can’t tell from the picture.