Trying Out the OpenVINO AI effects: They Fail to process!

I’ve just now discovered some new AI plugins for Audacity. However, when I try them out, I get the error that the plugin fails. For what reason I’m not sure. Here’s the file I’m trying to transcribe with the “Whisper” model.

Maybe you’re using the wrong version of Audacity, or the wrong version of the OpenVino module, or you haven’t installed it correctly. See this page: Releases · intel/openvino-plugins-ai-audacity · GitHub

The version of Audacity I have is version 3.4.2.0.

Hi @Annabelle3985,

Can you copy and paste the contents of Help->Diagnostics->Show Log?

Thanks,
Ryan

Here’s what I got in the diagnostic log.

17:09:31: Audacity 3.4.2
17:09:31: Error: Failed to load shared library ‘avformat-60.dll’ (error 126: The specified module could not be found.)
17:09:31: Error: Failed to load shared library ‘avformat-59.dll’ (error 126: The specified module could not be found.)
17:09:31: Error: Failed to load shared library ‘avformat-58.dll’ (error 126: The specified module could not be found.)
17:09:31: Error: Failed to load shared library ‘avformat-57.dll’ (error 126: The specified module could not be found.)
17:09:31: Error: Failed to load shared library ‘avformat-55.dll’ (error 126: The specified module could not be found.)
17:09:34: sqlite3 message: (1) no such table: project in “SELECT 1 FROM project LIMIT 1;”
17:09:34: Error: Failed to load shared library ‘avformat-60.dll’ (error 126: The specified module could not be found.)
17:09:34: Error: Failed to load shared library ‘avformat-59.dll’ (error 126: The specified module could not be found.)
17:09:34: Error: Failed to load shared library ‘avformat-58.dll’ (error 126: The specified module could not be found.)
17:09:34: Error: Failed to load shared library ‘avformat-57.dll’ (error 126: The specified module could not be found.)
17:09:34: Error: Failed to load shared library ‘avformat-55.dll’ (error 126: The specified module could not be found.)

avformat is part of the optional FFmpeg import/export library. I don’t think that’s related to your issues with the plug-in. And it’s probably not really an error. You probably just haven’t installed FFmpeg.

I’m not sure about the sqlite3 message but I kind-of doubt it’s related either.

I have all of Audacity fully installed, and I did install the OpenVINO plugins the right way, so I wonder what caused the error.

Hi @Annabelle3985,

Can you give screenshot of the error message?

Thanks!

I hope this works.

Hmm, strange. I’ll have to study the plugin code a little bit to figure out if I missed a case where the error dialog is thrown, but no specifics are added to the Audacity log. It was my intent to always have some specifics about what what wrong written to the log in this scenario.

Dumb question, and just double checking – you copied and pasted the contents of the log after the plugin failure right?

Thanks,
Ryan

I don’t think that’s a dumb question at all! Yes, I did indeed copy and paste the full contents of the log.

I had it fail, but I had to change the drop down from GPU to CPU each time and it worked.

For me, it fails whether I select GPU or CPU. What the soap is up with that, I wonder?

I have the same problem.

12:20:19: Audacity 3.4.2
12:20:19: Error: Failed to load shared library 'avformat-60.dll' (error 126: Das angegebene Modul wurde nicht gefunden.)
12:20:19: Error: Failed to load shared library 'avformat-59.dll' (error 126: Das angegebene Modul wurde nicht gefunden.)
12:20:19: Error: Failed to load shared library 'avformat-58.dll' (error 126: Das angegebene Modul wurde nicht gefunden.)
12:20:19: Error: Failed to load shared library 'avformat-57.dll' (error 126: Das angegebene Modul wurde nicht gefunden.)
12:20:19: FFmpeg libraries loaded successfully from: C:\Program Files\FFmpeg For Audacity\avformat-55.dll
12:20:26: sqlite3 message: (1) no such table: project in "SELECT 1 FROM project LIMIT 1;"
12:20:26: Error: Failed to load shared library 'avformat-60.dll' (error 126: Das angegebene Modul wurde nicht gefunden.)
12:20:26: Error: Failed to load shared library 'avformat-59.dll' (error 126: Das angegebene Modul wurde nicht gefunden.)
12:20:26: Error: Failed to load shared library 'avformat-58.dll' (error 126: Das angegebene Modul wurde nicht gefunden.)
12:20:26: Error: Failed to load shared library 'avformat-57.dll' (error 126: Das angegebene Modul wurde nicht gefunden.)
12:20:26: FFmpeg libraries loaded successfully from: C:\Program Files\FFmpeg For Audacity\avformat-55.dll
12:21:27: File name is C:\Users\ELA\Desktop\Planung\Feuerwehr Audio Dateien\Voralarm.wav
12:21:27: Mime type is *
12:21:27: Opening with libsndfile
12:21:27: Open(C:\Users\ELA\Desktop\Planung\Feuerwehr Audio Dateien\Voralarm.wav) succeeded
12:21:27: Operation 'Importiere WAV (Microsoft)' took 0,009000 seconds. Poll was called 3 times and took 0,000001 seconds. Yield was called 0 times and took 0,000000 seconds.
12:21:48: Operation 'Vorverarbeitung' took 0,000000 seconds. Poll was called 0 times and took 0,000000 seconds. Yield was called 0 times and took 0,000000 seconds.
12:22:13: Operation 'OpenVINO Noise Suppression' took 24,513000 seconds. Poll was called 49 times and took 0,170495 seconds. Yield was called 48 times and took 0,104094 seconds.
12:21:49: Error: In Noise Suppression Compilation, exception: Exception from src\inference\src\core.cpp:100:
[ GENERAL_ERROR ] Model file C:\Program Files\Audacity\openvino-models\noise-suppression-denseunet-ll-0001.xml cannot be opened!

12:22:20: Operation 'Vorverarbeitung' took 0,000000 seconds. Poll was called 0 times and took 0,000000 seconds. Yield was called 0 times and took 0,000000 seconds.
12:22:39: Operation 'OpenVINO Noise Suppression' took 19,445000 seconds. Poll was called 39 times and took 0,172857 seconds. Yield was called 38 times and took 0,111419 seconds.
12:22:20: Error: In Noise Suppression Compilation, exception: Exception from src\inference\src\core.cpp:100:
[ GENERAL_ERROR ] Model file C:\Program Files\Audacity\openvino-models\noise-suppression-denseunet-ll-0001.xml cannot be opened!

Hi @SAZ,

Can you double check if this file exists on disk?

C:\Program Files\Audacity\openvino-models\noise-suppression-denseunet-ll-0001.xml

Thanks,
Ryan

Hi @Annabelle3985,

Can you double check that C:\Program Files\Audacity\openvino-models has the following files?

I’m afraid I don’t understand. The link you posted is an image, which my screenreader doesn’t know how to read. Screenreader software can only read text and text-based icons.

Ah okay. Without screenshot:

Can you double check that C:\Program Files\Audacity\openvino-models has the following files?

ggml-base-encoder-openvino.bin
ggml-base-encoder-openvino.xml
ggml-base.bin

Thanks,
Ryan

Yes, all three files are there. I wonder if one of them might be corrupted.

Here’s another version of the log.

17:40:36: Audacity 3.4.2
17:40:36: Error: Failed to load shared library ‘avformat-60.dll’ (error 126: The specified module could not be found.)
17:40:36: Error: Failed to load shared library ‘avformat-59.dll’ (error 126: The specified module could not be found.)
17:40:36: Error: Failed to load shared library ‘avformat-58.dll’ (error 126: The specified module could not be found.)
17:40:36: Error: Failed to load shared library ‘avformat-57.dll’ (error 126: The specified module could not be found.)
17:40:36: Error: Failed to load shared library ‘avformat-55.dll’ (error 126: The specified module could not be found.)
17:40:39: sqlite3 message: (1) no such table: project in “SELECT 1 FROM project LIMIT 1;”
17:40:39: Error: Failed to load shared library ‘avformat-60.dll’ (error 126: The specified module could not be found.)
17:40:39: Error: Failed to load shared library ‘avformat-59.dll’ (error 126: The specified module could not be found.)
17:40:39: Error: Failed to load shared library ‘avformat-58.dll’ (error 126: The specified module could not be found.)
17:40:39: Error: Failed to load shared library ‘avformat-57.dll’ (error 126: The specified module could not be found.)
17:40:39: Error: Failed to load shared library ‘avformat-55.dll’ (error 126: The specified module could not be found.)
17:40:59: sqlite3 message: (283) recovered 34 frames from WAL file C:\Users\Annabelle Baradine\AppData\Local\Audacity\SessionData\New Project 2024-01-12 17-37-23 N-1.aup3unsaved-wal
17:40:59: Loaded 70 string 1.453125 Kb in size
17:40:59: Project loaded in 19 ms
17:41:32: Operation ‘Export’ took 0.140000 seconds. Poll was called 3 times and took 0.000002 seconds. Yield was called 0 times and took 0.000000 seconds.
17:42:47: sqlite3 message: (1) no such table: project in “SELECT 1 FROM project LIMIT 1;”
17:45:00: sqlite3 message: (1) no such table: project in “SELECT 1 FROM project LIMIT 1;”
17:45:10: File name is M:\My Documents\Telephone Tones\Miscellaneous Tones\Telephone Company Repair Service, Dial 611.wav
17:45:10: Mime type is *
17:45:10: Opening with libsndfile
17:45:10: Open(M:\My Documents\Telephone Tones\Miscellaneous Tones\Telephone Company Repair Service, Dial 611.wav) succeeded
17:45:10: Operation ‘Importing WAV (Microsoft)’ took 0.022000 seconds. Poll was called 3 times and took 0.000002 seconds. Yield was called 0 times and took 0.000000 seconds.
17:46:21: Operation ‘Pre-processing’ took 0.000000 seconds. Poll was called 0 times and took 0.000000 seconds. Yield was called 0 times and took 0.000000 seconds.
17:46:21: Error: In Whisper Transcription Effect, exception: whisper.cpp context creation / initialization failed
17:46:33: Operation ‘OpenVINO Whisper Transcription’ took 0.098000 seconds. Poll was called 2 times and took 0.000002 seconds. Yield was called 0 times and took 0.000000 seconds.
17:46:21: Error: whisper_init_from_file_with_params(C:\Program Files\Audacity\openvino-models\ggml-base.bin, …) failed