Truncate Silence not working via Macro / Batch Processing


I am struggling to get ‘Truncate Silence’ to work on multiple tracks via a Macro. Is it a bug, or is it my configuration?

The settings in the Macro work.

  • If I process 1 audio track, it will truncate silence.
  • If I select all/multiple tracks, it will only truncate 1 audio track.

My goal is to have the Truncate Silence work for me like I do Normalize: I load many tracks into Audacity, ctrl+A, select my Normalize macro, it processes every track, I continue working.

Can somebody test this for me please?

I’m using Windows 10 (Version 22H2) and Audacity 3.3.3
My audio files are .mp3

Help is much appreciated.


Here is what I get when I apply this macro to the current project:

TruncateSilence:Action=“Truncate Detected Silence” Compress=“50” Independent=“0” Minimum=“0.5” Threshold=“-20” Truncate=“0.5”



Perhaps I am missing something?

Hey thanks for trying! I copied your test and I was successful. However in my real work environment the problem remained. I was very confused.

I’m happy to have resolved the problem now. I had simply missed a button on the effect: Truncate tracks independently

With this setting checked, it will select all and truncate all! Interestingly though, this setting is not used in the test I copied from you, and it still worked.

However, I’m very happy now. I will call it case closed.


Thanks for posting your solution. :grinning:

This topic was automatically closed after 30 days. New replies are no longer allowed.