Trouble with USB connection Pyle Cassette [SOLVED]

I have been using a Sony turntable and a Pyle cassette tape deck, both with USB connection, to transfer my albums and tapes to my MAC using Audacity. My turntable still works just fine but the cassette deck is no longer recognized. I’ve tried changing all the input settings but nothing seems to work. Looking for suggestions.

Forget Audacity for a minute. Plug the Pyle in and let it sit there for a bit so the Mac recognizes it. Does it have a little light and does it come on? A USB light?

Apple (upper left) > System Preferences > Sound > Input. Your machine may have these slightly different.

Do you see a USB Sound Device or Pyle-something-something?

Audacity gets its sound from the Mac, not the Pyle. If the Mac can’t find it, that may be the end of the world.

If you have a much better quality, non USB cassette machine, it’s not terrible to adapt that to your Mac. The quality may be better as well.

I can be a little ray of sunshine here and say these USB devices are designed to fail and be thrown in the trash. Sometimes they fail a little too early.

It could be the silly problem that Audacity checks for connections when it starts. Connect first, wait a beat and then start Audacity. You can also Transport > Rescan.


Thanks, Koz. I’ll try your suggestions.

This machine does have cable output, which works just fine, but I’m not sure how to input to the Mac? Do you have advice?

The USB cable…

… can go both ways.

Does the Pyle have a little USB light on it? What is the model number so we can look it up?


I finally figured it out! My USB cable was too long! I went back to the original shorter cable and the Mac found the Device which is Pnp and not Codec as is the Sony Turntable. Everything is now working again. Thanks for your input!