trouble with ffmpeg[SOLVED]

I have a mac running 0sx 10.7.5, I’m using audacity 2.0.3 I want to convert mp3 to wma but it can’t seem to find ffmpeg and the file libavcodec.52.dylib, no matter where I put it.

I have followed the instructions precisely, downloaded the zip file version (several times, from the wiki page, and from the download link in the program from preferences/libraries/locate ffmpeg), placed it on the desktop, and tried putting it inside the audacity application folder with no luck. I have been through the forum looking at the “can’t find ffmpeg” and followed the advice there, again with no luck.

This is what happens. Start Audacity, go to preferences/libraries.

(A) window says “FFmpeg Library Version: FFmpeg Library not found”
(B) I click on “Locate”, window tells me “Audacity needs the file ‘libavcodec.52.dylib’ to import and export audio via FFmpeg … Location of ‘libavcodec.52.dylib’:”
(C) it then displays the location in the white bit – “/Applications/Audacity/libavcodec.52dylib”

This is the location where I put the file(s). The file name got into the window from me finding it with the “browse” feature

(D) I then click “OK”, and we return to the previous window at (A) above, still saying not found.

(E) regardless, I click on OK and return, restart the program, restart the computer, but still says no library.

Help!, What Am I Doing Wrong?


ps the preferences/libraries window shows the mp3 library version: LAME 3.98.2, and if I go to its location it is also in the applications folder, where I only just put it, so it seems to have found that ok.
I have also unlocked and changed permissions on the folder to read/write for everyone

Moved to the Mac OS X board.

You have to extract all the files from the zip. If you move the files, move all of them.

Audacity > Quit Audacity.

Trash the other downloads of the FFmpeg zip and contents.

In Finder, click Go > Go to Folder then type:

~/Library/Application Support/audacity/

Open audacity.cfg in TextEdit and remove all the content, except leave the following line at the top so that this is now the only contents:


Save the changes to audacity.cfg.

Download the following FFmpeg installer which installs all the files to Library/Application Support/audacity/libs: . Run the installer and don’t change any installation paths.

Launch Audacity, then Audacity should see FFmpeg without further configuration.

If not, please post the content of Help > Show Log…


hi Gale

worked a treat, thank you very much.

I have a 30 hour drive ahead of me and the only audio I can take with me are either .wma – or an ancient cassette tape player!