Trouble with Audacity 3.0.2/Windows 10


I regret the length of this post but as I have been struggling with various issues since February 2021, I think it is important to list all that has happened as it might help suss this situation out.

I have been using Audacity (whatever the newest version) for 2-3 years to record voice over. I am not tech savvy, but I do try to learn and do as much as possible. So…

  1. Moved my studio into a new bedroom in February 2021 and set it up with a new ASUS touch screen monitor, keyboard/mouse, Logi video camera and a hub for wire connections so that I could keep my laptop (ASUS) outside my booth to lower noise floor.

  2. Started experiencing electronic pops and clicks that only occurred when I was speaking into the microphone. Verified that they were, indeed electronic in origin as they were visibly different than my own vocal waveforms when expanded sufficiently. (And yes, also had an audio engineer look at them and he confirmed electronic as well.) It should also be noted that the electronic garbage noise only occurred AFTER I did a punch and roll. If I was able to do a perfect take…I do audiobooks, so no such luck, then there was no extraneous noise.

  3. Went down several different rabbit holes trying to problem solve. Clocking speed discrepancies, best recording host, maybe a new audio driver (ASIO)?, how much RAM do I have/need?, etc. I could not pinpoint it, and hilarity ensued. After determining that the 8 GB of RAM in my little lap top was minimal and not upgradable (image of me shaking my fist at the decision makers at ASUS) I decided that I could not do more trouble shooting to find the problem…I did mention my lack of tech knowledge, yes?

  4. Spent money on credit to purchase the components and build a new tower for my VO work (Yes, I got help from those who know-the new tower is sound and more than I need for my work). Extra water cooling system, two SSD, one with 2 Terabytes for long term storage, 32 GBs of RAM with slots for more (Replay image of me shaking my fist, with central finger extended at the ASUS gods], and the bonus of a gaming husband with Tower envy. I learned a great deal, and now had a new system that could not possibly be the problem…

  5. Since I was mid book when this went down, I had some recordings from before (I think I was using either 3.0.0 or the one before), I tried to edit and fix them, but ended up re-recording as the Audacity software was slowing way down and taking several minutes to process a simple command. I figured that the 3.0.0 or the unsolved electronic issues were to blame, shrugged and redid the work.

  6. I have since gotten offered a second book which is due in 10 days, plus I am still working on the book mentioned above. Relevance, you ask? Today I was trying to get several chapters of the new book edited, and Audacity’s response time started to slow way down…then I thought maybe I should uninstall/reinstall and use CCleaner to make sure any bits were gone.

  7. So to be extra careful, I backed up my current work on the second book into my 2 terabyte long term storage. I uninstalled Audacity 3.0.2, and I ran both CCleaner and Smart Driver just in case. I then reinstalled Audacity 3.0.2.

  8. I tried to bring up the chapter I was working on to master and submit it…it will not come up. Instead I get the pop up box in the image attached below. Besides said pop up box, I am also being told when I open Audacity that, “the previous file(s) were not saved properly.” Unless there is some secret hand-shake I have not been privy to, this is not true. I save frequently, and always at the end. Of course, when the the system slows to anywhere from 2-10 minutes when asked to save or any other simple task…Finally, there were several other error boxes that come up when I try to retrieve my file. They are also attached below with titles.

Please, please, please help me. I have a deadline, and I am feeling absolutely overwhelmed and out of my depth with this. Did I mention the deadline and lack of tech knowledge?

Many thanks in advance,

Devon Enyedy

PS There are other pop up boxes but I suspect you get the idea…again my thanks.
Audacity Project File Not Closed 7.5.21.png
Audacity Title of File When Trying to Pull Old File 7.5.21.png
Audacity Not Saved Properly Pop Up Box7.5.21.png
Audacity Error Image 7.5.21.png

If you have an Audacity .aup3 workspace that you are unable to open, zip it up, post it on a public file sharing service such as dropbox and send me a link via private message. I’ll take a look at it.

Other than that, let me suggest that to lower your blood pressure, uninstall all current versions of audacity, then download and install Audacity 2.4.2 from here and run with that for your current project: Note that 2.4.2 will NOT be able to open any .aup3 project files, so be sure to save your work in .WAV format before you do this.


I have sent a message to admin as I cannot currently access private messages to send you a link to my zipped file now in google drive. Quick question-I started to convert my current Audacity files to waveform, and I noticed several encoding options for various “bits”, both in terms of number-16, 24, 32; and in terms of type-PCM, float, etc. Which should I use if I am going back to Audacity 2.4.2 as you suggested in your initial reply?

Many thanks for your help,


Checking in to this…

If the work is unfinished, as I assume it is, it is best to export as 32-bit float.

You should be able to now.

Thank you, Steve.

I really appreciate your patience with novices.



I can reproduce your “An unhandled exception occurred” error. I have tried a couple of trick to try to rescue the data - but so far no luck. In the meantime, I have forwarded your link to the developers.

The developers have been able to extract your .wav file and are looking into the root cause of the problem. I have sent you a PM with the link to the extracted file.

Hi Again Jademan,

I do wish I did not have to keep asking you for help, but here it is. Yesterday I was able to get the file that the developers extracted back into audacity, finished the mastering, and submitted to ACX. Yeahhhh!

So then I went and converted all my files that I had converted to WAV back into audacity 2.4.2. The wave form looked fine so I did not think anything of it and just assumed the settings on the pop up box were correct…whoops. Now the speed is wrong and I sound a bit like a feminized Lurch from the Addams Family. I am also feeling a bit like an ass for assuming.

Could you tell me how to convert back to Audacity so my speed is the same?

VERY much appreciated,


I have a simple solution to this, but others have had broader experience with this, and their solutions may be quicker and better. I have to step out right now, but I have asked others to help you with this in the interim.

I expect that it’s a sample rate mismatch.
The first thing to do is to try and work out how far out the speed is. When we’ve done that, we will hopefully be able to fix it.

  1. Select part of the waveform
  2. Adjust the slider a bit to the left (left = slower / lower pitch. right = faster / higher pitch) and click the “Preview” button.
  3. Repeat step 2 with different slider positions to find, as closely as possible, the position that makes it sound normal (correct pitch and speed).
  4. What is the “Speed Multiplier” when it sounds normal?
  5. Click the “Cancel” button to close the effect without applying.

Hi Steve,

I figured out what slider you meant (Change Speed in the FX, right) and I think 1.081 to the right seems to fix it for all four of my files. Now, do I just apply said speed change using the same FX?

Thank you,



Thank you very much for your help here. I am unsure why this is happening.


The developer said there were tons of envelope control points such as might be created with the Envelope Tool. Are they something you put in and if so, how do you use them?

No, don’t do anything yet.

That’s very close to what happens when a 44100 Hz sample rate is played at 48000 Hz.

Look in the information / control panel on the left end of the track. Does it say “44100” or “48000”?

No, they are all at 41000, but I think I originally recorded them at 48000 on the advice of a friend of mine. I would then switch them to 41000 before running them through 2nd Opinion and uploading to ACX. Is that a bad idea? The friend uses Reaper and is less familiar with Audacity. He keeps trying to get me to switch to Reaper or another DAW as they have more tools; I have been hesitant as I am such a newbie, and I find Audacity perfectly serviceable… not to mention that the interface is far less intimidating!

I did go through and in the hope that you would tell me I could use the “Change Speed” FX, did that and then edited, mastered, Second Opinion Checked, and submitted two of them. They sound just fine to my relatively novice ears. I am not trying to get ahead of your expertise, but I am on a deadline, and between this and the prior issues I have had (see original post) I am getting very antsy about finishing this project on time. Yes, I did message the rights holder, and yes he is fine with it being late as the tech stuff is beyond my control. Still, I want to be a producer that people can depend on, and I have only done a few books so far.

At any rate, if I need to go back and redo or change something to make this right, I will do so.

Again, I am MOST grateful for your help,


Whoops, did not see this question until just now. I have never used the envelope tool. I only use the selection tool. I do, however, use the Amplify FX to change the volume when I occasionally get too loud or soft in a specific piece of narration.


Thanks for this info; it has been forwarded to the developer.

For ACX recordings it’s probably better to record at 44100 so that you don’t need to convert later.

In cases where you do need to change the sample rate, the correct way to do it is with “Tracks menu > Resample” (

To fix the problem:

  1. Use “Tracks menu > Resample” to change the sample rate to 48000
  2. In the track’s dropdown menu, change the “Rate” to 44100 (see: