Trouble updating plugins - LAME +

I downloaded new Lame_Library v3.99.5 and ffmpeg (2.2.2) plugins, and ran the installer package for each.
After installing, Audacity Preferences > Library shows LAME 3.98.2 (Location is: usr/local/lib/audacity/ )
So Audacity does not seem to be recognizing the newly installed Lame library.

For the mpeg plug in, after installation, i don’t think the version recognized is the current one (not certain). Audacity shows: F(55.33.100) (Location is: Library/Application Support/audacity/libs/ )

I’d be grateful for any tips on how to get Audacity to recognize the latest plugins - and how to delete old ones!

I’m running Mac OS X 10.11.6 / Audacity 2.3.0

  • Will

First, use the Finder’s Go > Go to Folder menu to go to /Library/Application Support/audacity/libs. Make sure the file libmp3lame.dylib exists in that folder. This is where the installer puts the file. If it is not there, try running the installer again.

Next, use the Finder’s Go > Go to Folder menu to go to /usr/local/lib/. Open the audacity folder and delete the libmp3lame.dylib file.

Start Audacity. It may complain that it can’t find LAME and offer to find it. If it just starts normally, go to Audacity > Preferences > Libraries and look for the libmp3lame.dylib file.

You have the correct ffMPEG dylibs, in the correct location.

– Bill

Thank you Bill, that worked.

It looks like there are other outdated files in usr/local/lib/audacity
There are 3 files there (plus 3 aliases): libavcodec.52.dylib, libavformat.52.dylib, libavutil.50.dylib

It seems there are newer versions of these in /Library/Application Support/audacity/libs

So should I delete all the files in usr/local/lib/audacity/ ??

  • Will

Glad it worked. Yes, delete the old files in user/local/lib.

– Bill