Trim silence from start and end only

I’ve seen websites mentioning there’s a trim silence option, that works like truncate silence but only removes the silence from the start and end of an audio track, rather than everywhere in an audio track. I can’t find that option in Audacity 2.1.2 for El Capitan. I know I can remove the silence manually, but I’d like to automate it with a chain. How do I access the trim silence option?

There’s a plug-in available here:
Note that the plug-in has to load the entire track into RAM, so it is not suitable for very long tracks. Assuming a sample rate of 44100 Hz, it should be OK with tracks up to about 45 minutes.

See here for download and installation instructions:

If you use truncate-silence with a “detect” duration which is longer than any silence* in the track, then it should only trim silence from the ends which exceeds the detect duration.
[ * in this case “silence” = sound below the “level” (threshold) set in Truncate silence tool].

I followed the directions and put TrimSilence.ny in the plug-ins folder and restarted Audacity. It doesn’t show up anywhere. There’s also an entry in the plugins manager that doesn’t have a name:
If I enable it nothing happens, and when I go back to the manager it’s disabled again. Also, if I delete everything in the plug-ins folder, there doesn’t seem to be any difference, and everything seems to work normally. I checked to make sure this was the only version of Audacity installed and the only plug-ins folder. I also deleted Audacity and reinstalled it. In the preferences pane, under effects, all the options are checked. I’m using Audacity 2.1.2

Select “New” (top right), then scroll down to the lower case effect names.

I don’t see it there either. This is the new tab:
This is what the disabled one looks like:

I accidentally said I’m using El Capitan. I’m actually using Sierra.

I followed one of the posts in this thread and it worked:

I ran the from Terminal, now the plug-ins are showing up properly.

Sorry about all the posts. It seems the plugin only works if I continue launching from Terminal. If I launch Audacity by running the plugin shows up but I get the following error when I try to use TrimSilence:

Effect failed to initialize
Attempting to initialize the following effect failed:
Trim Silence
More information may be available in Help->Show Log

In the log I get this:

20:35:29: Error: dlopen(.bundle, 2): image not found

For now I’ll just continue running Audacity from inside the package.

It looks like Audacity isn’t installed properly.
That’s likely to be due to one of two reasons: either you’ve not installed it properly, or Gatekeeper has stopped it from being installed properly.
I think best we take this a step at a time so that we fix it the right way.

Firstly, let’s check whether Audacity is installed correctly:

  1. Look in the Effects menu for an effect called “Nyquist Prompt”. Is it there?
  2. Look in the Generate menu. How many generator effects are listed, 5 or 8?
  3. Quit Audacity from the File menu, then restart Audacity, then “Help > Show Log”. Save the log and attach it to your post (or copy and paste it into your post).

The instructions here are how Audacity ‘should’ be installed:
The most important part is that you do not run Audacity directly from the DMG file. You have to “mount” the DMG, then drag the entire “Audacity” folder icon in the DMG window into the /Applications folder, then when it is finished, eject the DMG.

Please be totally clear about this - I don’t want to start messing with Gatekeeper until we’re absolutely sure that you have done this bit right AND that the problem is what I think it is.

Ah ha, that makes sense. Was it an update from El Capitan to Sierra?