Tracks lacking "power"

I use Audacity to edit my dj sets that I record through Virtual DJ. When I import one of these recordings into Audacity, the whole track will have large amounts of clipping here and there, so I use the amplify effect to de-amplify the track to bring down the peak amplitude to 0 dB. The problem is that after that my tracks sound too soft. I usually work with electronic dance music, so it’s essential for me that these tracks come out with “punch” and “power”. What can I do?

If you recorded a set from your mixer and it sounded good going to the floor, you should be able to record the mixer “Tape-Out” and set the levels for a good, clean recording in Audacity. After that, play the track back into the mixer and on to the floor. Adjust mixer levels as needed. There should be no difference between the two shows.

If you’re not playing Audacity to the floor, then you can apply Effect > Compressor or Chris’s Compressor to make the show denser and louder in your iPod or other personal Music Player.

Clipping and overload are sound damage and as a rule are permanent and to be avoided. Most systems can’t record “reality” without a little help.


Koz, thanks for your reply. The sets are recorded within the Virtual DJ software while I’m mixing live. The software outputs the signal (the same that is being recorded, presumably) through an external sound card, and this signal goes directly to the PA system. If I understood correctly, to apply your advice to this setup I should adjust my levels down in the dj software to get a clean (i.e. no clipping) recording, and then increase the levels of the PA mixer to make sure it’s going out loud enough?

Since I’m not playing to the floor from Audacity I’ll give the compressors a try and report back on how that goes.

No. You may be stuck with that one. The only way to get a recording in that case is record “Stereo-Mix” or “What-U-Hear” and in those cases, the floor volume and the Audacity volume are probably the same. You can’t split them – usually. On many machines, the two volume controls track and you can’t stop it.

Or worse, the floor will get your mix plus the playthrough Audacity delay.

It could be said that if Audacity is distorting, then your floor mix is distorting, too. Audacity doesn’t apply filters or effects during recording. What the computer gets is what we get.

I’ve been known to use a separate computer or recorder.

Does the DJ software have provision for recording?


I’m not sure what you mean with “Does the DJ software have provision for recording?”

The dj software gives me an mp3 recording of the sound it outputted during recording; the recording is made within the dj software, I’m not recording anything through Audacity. This mp3 recording, when played unedited through any mp3 playback software, sounds fine, no audible distortion. But when I import this mp3 into Audacity, it shows that there’s clipping (I play at a small venue with a small PA system, so find myself having to increase my levels to get a loud enough sound to the floor). As you can see I’m not a pro, but I’ve been told that clipping should be avoided at all costs, which is why I use the amplify effect to de-amplify to a peak of 0dB, thus eliminating the clipping. But this leaves me with the aforementioned lack of punch and power.

Having said this, I just tried with one of my raw recordings to use the compress effect with the threshold all the way to the right at -1 dB, leaving all other parameters default but activating the options for Make-up gain for 0dB and Compress based on Peaks, instead of the amplify effect, to get rid of the clipping. This seems to yield a better result.

I’m not recording anything through Audacity.

I know people who record their sets using pathways separate from the show. They have no “off-line” show. Everything they do is to a live floor.

In general you can’t “get rid of clipping” in post production. Once the sound hits or passes 0dB – the red lines show up in View > Show Clipping, or the sound meter lives all the way to the right and turns on the little red bar – it’s too late. Turning the volume down to stop Show Clipping lines just decreases the volume of the distortion. The distortion doesn’t go away. People who misuse the Mic-In on their laptop run into this all the time. Those overload and clip well below 0dB. “I don’t have red clipping lines , but the signal never goes above -6 and sounds terrible.”

There is one time where you can fix Show Clipping lines without distorting the sound. “Show Clipping” kicks in at 0dB, but distortion only occurs over that. It’s not unusual for conversions from high quality formats to MP3 to create very tiny clipping points that look terrible on the Audacity timeline – a sea of red – but don’t actually sound all that bad.

But most live recordings do actually clip. Sheers the tops and bottoms from the blue waves leading to harsh peak notes and dense, crunchy recordings (Illustration).

That said, I do have techno/dance tunes that appear in Audacity as solid blue waves. They’ve been processed and compressed to within an inch of their lives and live right at the 0dB clipping point without going over. They sometimes have a pumping sound (the voice or instruments duck when the bass notes go by).

Converting those to MP3 will create a solid block of red since MP3 always creates distortion and changes the waves .

Picture: Those flat tops and bottoms are created when the sound gets too loud for the channel or recorder. The peaks are clipped off. Here I have reduced the volume of the sound in post production so the red lights/bars no longer appear, but the distortion is still there and the show still sounds crunchy. Koz
Screen Shot 2013-05-03 at 4.15.06 AM.png

…to use the compress effect…

Try Chris’s Compressor for a denser, louder, more even sound without apparent distortion.

I change the first value, compression, from the default 0.5 to 0.77 or higher.


Here’s an example of a piano that does not set the overload lights or red bars, but is intensely distorted from overload/clipping before Audacity got to it. Nothing we do is going to fix that. Koz

If you want push the volume to the max, try Steve’s brickwall limiter … [ too brutal for classical music , but ideal for “electronic dance music” ]