Tracks go out of sync when using compressor

I’ve multi tracked and everything was synched perfectly. I then selected compressor and several tracks became out of sync. I’ve tried selecting all and compressing all at once, then tried compressing each track individually but the same thing happened. Any ideas why this is happening?

Some plug-ins/effects introduce delay, but I don’t think that should happen with Audacity’s built-in effects…

You may have to re-synchronize everything manually. :frowning:

Most DAWs have Plug-in Delay Compensation, but Audacity (a “simple audio editor”) does not.

I can’t think of anyway other than manually - it is very strange!

It sounds like a bug. Which exact version of Audacity are you using, and which operating system?

Hi Steve, it’s 3.2.4 os windows 11

I don’t personally use Windows, but perhaps a couple of screenshots (before and after applying the compressor) and what setting you are using in the Compressor, may help others to reproduce the issue.

Thanks Steve. I’m using the preset settings. I don’t think I can screenshot the problem because the unsync seems to be random and it doesn’t apply to all tracks (there are 16 tracks)

Could it be this bug? Compressor produces corrupted audio when blank space is selected ahead of the audio · Issue #5670 · audacity/audacity · GitHub

It could be as I just selected the whole track

I’ve managed to apply compression to the whole track, but I had to highlight each clip separately and even them it pushed 2 clips out of sync - I was able to time shift them back so all done but it would be good if that problem was sorted so it doesn’t happen again. Thanks for your help

Did you Save and/or close any joins before compressing

Hi rsotob I didn’t do that but have put other effects on and all has worked ok. Thanks for your help

This topic was automatically closed after 30 days. New replies are no longer allowed.