Tracks Exported As M4A (AAC) Files (FFmpeg) No Longer Play [SOLVED] on iTunes

Mac OS: 10.14.4
Audacity: 2.3.2

I’ve spent several years gradually converting a large vinyl jazz record collection to digital format. I’ve exported the individual tracks to M4A format using the FFmpeg library plugin to Audacity and loaded the files into iTunes where the tracks can be played and loaded into mobile devices libraries. This has worked flawlessly during this entire project.

Yesterday I went to add a final few recordings to iTunes and found that many, but not all, of the exported files would not play. I went back to examine files that had been added over the years, and most (about 90%) of those files will no longer play either. M4A files created by iTunes when importing CDs are unaffected; they all work fine.

I tried exporting a few tracks as MP3 files, and the MP3 files work fine.

I attached 2 screen shots to show what is happening when attempting to play the M4A files in iTunes. Screen Shot 1 shows what is displayed in iTunes before playing a track (which previously has played for years). Screen Shot 2 shows what iTunes displays after attempting to play a track. As shown, Screen Shot 1 shows a Charlie Parker album and the list of tracks appears normal. Screen shot 2 shows the same album after attempting to play tracks. The difference is Screen Shot 2 shows corrupted track time lengths, for example all tracks show the same corrupted time length of “789:57:13” instead of the actual time length of the track. iTunes will not play such tracks, but will skip to the first track that doesn’t have the corrupt time length displayed.

I’ve tried this on 2 different Macs running the same version Mac OS and iTunes, and the results are the same.

I suspect something changed in iTunes to cause this problem. iTunes appears to no longer be compatible with the M4A files produced by Audacity. I don’t know if this is a bug with iTunes or some problem with the FFmpeg library. In any case, unless it’s an iTunes problem, this is a disaster for me. I would have to go back and re-export many thousands of tracks as MP3 files to restore the music library.

Is anyone else having this problem? Is there anything I can do to avoid re-exporting the entire music library?

Screen Shot 2.jpg
Screen Shot 1.jpg

This problem is believed to be a bug in iTunes: 12.9.4
I have iTunes: and I see the same problem.

There’s a workaround, which is to bulk rename all m4a files from “.m4a” to “.mp4”, but don’t do that yet.

It has also been reported that the latest update of iTunes fixes the problem. I’m not yet able to confirm this as I’m waiting for the update. I hope to be able to give more information shortly.

The problem is fixed in iTunes Version

I had to run updates manually (from “System Preferences > Software Updates”) in order to get the update, and it was a very slow update (took about 30 minutes to complete).

If, after the update, the track lengths do not update automatically, just right click on the song and select “Song Info”.

Thank you, Steve!

I initially tried to do the upgrade, but the system showed no updates available. Going into System Preferences worked to get the latest. I upgraded to iTunes and the problem was resolved! For tracks that still showed the incorrect track length, just hitting the play button was all that was necessary to display the correct value.

What a relief!

Terrific :slight_smile:
I’ll close this topic as “solved”.