Track length varies when exporting audio

Hi, I’m using Audacity 2.1.0 in a Windows 8.1 x64 PC, and I’ve found a bug.

I’ve imported into Audacity a FLAC audio track, which length is 4m 10s 435ms. I’ve exported it to mp3 (transcoding) using latest LAME version 3.99.3. The output mp3 file’s length is 4m 10s 485ms.

So Audacity is adding 50ms more of silence, from the start/beginning of the song. I’ve noticed it cause I’ve zoomed in the 2 tracks (previously imported into Audacity) to compare both and hear to the possible quality loss, and I’ve seen that the tracks were not matching. I’ve used 2 output settings: best variable bitrate with standard speed and 320kbps constant bitrate. Both settings have the same result, an mp3 50ms longer.

Not big deal, but I think it’s an important bug to fix, since audio sync is really important.


That’s a normal characteristic of MP3 encoding. As I’m sure you know, MP3 is lossy compression so there are changes…

If it’s a problem, use a different format. As far as I know, AAC and OGG don’t have this issue. Or, use a lossless format.

Yeah, MP3 is lossy, it compresses data and the sound quality worsens. But in any way the length of the track should be changed. It’s logical.

I’d like to use MP3 cause I’m working with songs.

AAC does add silence padding, OGG doesn’t.

Please see


Wow, I didn’t know that. I don’t understand very well why you need to add silences, but it seems to be that it’s necessary in order to playback correctly and MP3?

Thank you very much for the info.