TouchPad Scroll doesn't work

Hi! :slight_smile:

So I’ll give some precisions regarding my situation:

  • I inistalled Audacity (versions 2.05 & 2.06, even if it doesn’t change anything) on 2 Laptops, my old & new ones. & the 2-finger scrolling function is working only on my old PC. I did every thing the same way though.
  • My Touchpad (on the new PC) works pretty well, & every other feature seems to work properly on Audacity, so I don’t understand why this one is missing :frowning:

Any idea? Thx

Audacity does not support “gestures” on touchpads or other devices - that is a “feature request”, so I’ve moved your post to the “Adding Features” board.

If 2 finger scroll worked on your old computer, I would guess that was due to your old computer performing software emulation of the gestures to convert them into standard mouse command (or some such).

I think this is more useful in the Windows board since two-finger scroll does work in Audacity on some machines on Windows. Moved back.

If 2.05 and 2.06 are not typos, please obtain the official latest 2.0.6 from

Touchpad scrolling (two-finger vertically/horizontally) does not work universally in Audacity on Windows. It may work more consistently when we upgrade to a more recent version of the wxWidgets interface kit that we use.

Are you saying that two-finger scrolling works in Audacity on one machine and not the other? Or two-finger scrolling does not work in any application on the one machine?

You could try looking at the Touchpad settings (probably in the Windows Control Panel), make sure you have the latest touchpad drivers, or try this: Details of that mod are at

For safety I suggest you use the direct download link I gave you.

Without that mod I can two-finger horizontally scroll in Audacity in Windows 7, but not two-finger vertically scroll. With the mod I can do both.

You can always scroll horizontally in Audacity by holding SHIFT and using a mouse wheel or ball.


Thx for your answers!
I didn’t precise it, but my both PCs run on Windows 8.1, & yea the old 1 allows me to scroll horizontally (I never needed vertically so I can’t say);
I didn’t think to the difference between my PCs’ touchpad drivers, that’s a good point.
I always check the Touchpad settings when I buy a new machine, & there is no prb with the 2-finger gestures :slight_smile:

I didn’t put it in features request, as it was working on the old one, so I thought this was already part of the software, or the driver/PC… :mrgreen:
But even if the driver is up to date (according to Windows, cause I had some bad surprises using…), the scrolling feature is not working perfectly every time (so out of Audacity I mean there). So I guess the prb might be there, indeed.
So I’ll try the mod you proposed, & say if it works better :slight_smile:

I verified, & here may be an explanation of the difference: my new laptop is an ASUS & its Touchad is ASUS built in… They made their own driver, no Synaptics there! xD
This must be why I got an error trying to execute the “twofingerscroll” file ^^

Yes, the mod is only for Synaptics touchpads, but most touchpads on Windows machines are Synaptics.

I’m still not really clear on whether the two finger vertical scroll only fails in Audacity or doesn’t work at all. However you might find an answer here Some people have got ASUS touchpads working on Windows 8.1 by forcing a driver update for Smart Gestures from the system tray or looking for a “Smart Gesture driver” for Windows 8.1 on the ASUS site. See here in particular .

Going to generic driver web sites probably isn’t going to help.


Ok, thx for the links, I’ll see that in a few days I hope, & anyway you gave me the way to scroll with a mouse, so we have an alternative solution :slight_smile:

Hey every one! :smiley:

Sorry to put this sleeping topic up now, but I just wanted to feedback: I looked at the discussion on the Microsoft forum, but as my issue didn’t seem to me as the same as theirs, I didn’t try to force the update of the driver by security (some amazing situations happened to me before :laughing: ).

But as I said, the solution is in the Shift key: with a mouse, but with the touchpad too! By scrolling vertically with fingers & holding the Shift key, it does the same effect as the mouse. I don’t kniw why I didn’t think to it earlier! :unamused:
So may be the real solution was in another driver, but yours was enough for me, thanks :exclamation:

Thanks. With my Synaptics touchpad, SHIFT does nothing, with or without the mod I mentioned, so I have to use two-finger horizontal scroll.