Time sync problem

I use audacity to record my church’s sermons and during the playback, a click sound shows up that sounds much like a metronome. I’ve been told it is a time sync issue between our sound board and Audacity. Is there a way to make the audacity time slaved to the mixer’s time?

I am using a Yamaha TF5 with a Yamaha Dante card and a Dell PC (64-bit) with Windows 10 Pro. Audacity is up to date.

Some mixers do have a metronome output.

The only possibly relevant control is to change Audacity’s project-rate from the default 44100Hz to 48000Hz
TF5

The settings are at 48000 Hz. The TF series does have a metronome feature but the click is intermittent. Not sure what else it could be.

If I have to I can continue editing it out but I was hoping there was a better solution.

Intermittent clicks can be dropouts, (a/k/a skipping) …
https://manual.audacityteam.org/man/faq_recording_troubleshooting.html#How_can_I_record_without dropouts