Time delay when recording.

hi guys,

does anyone have any solutions to the problem of time delay while recording.
the first mic i tried was a Editors keys SL300 USB which had this problem so i bought a Behringer USB interface and Rode NT1-A XLR mic but i still have the same problem and in fact the timing is running out even worse than the USB Mic.
when i record a vocal track next to the backing track its out of sync.
very annoying.
Can this be solved during recording ?

Ensure that your headphones are plugged into the audio interface.
Then set up “latency correction”. See: https://manual.audacityteam.org/man/latency_test.html

See [u]this page[/u].

There is always latency (delay) through the computer but it can be compensated for. It’s caused by the buffers, and recording & playback buffers are required because of the multitasking operating system.

…Latency is normally only a problem if you’re monitoring yourself through the computer and the delay makes it difficult to perform.

Hi Doug,
yes thats what im doing monitoring through my pc and its very annoying hearing the delay of my vocal. it puts me off.
if my headphones are plugged into the interface will i still hear the backing track in audacity ?

cheers steve,
ive manage to solve it by going to preferences and allowing playback through the interface.

You need to set the “Recording device” in Audacity’s “Device Toolbar” to the audio interface. Device Toolbar - Audacity Manual

Also, ensure that “Software Playthrough” is “OFF” (not selected) and “Overdub” is “ON” (selected) in “Transport menu > Transport options” (Transport Menu: Transport Options - Audacity Manual)