"There is not enough room available to paste the selection"

Audacity 2.4.1 – Windows 10 home version 1903 – 8G RAM – 500G free hard drive space

In the Effects menu, I’m trying to “Studio Fade Out” a small section, about 5 seconds long.

Audacity error pops up “There is not enough room available to paste the selection.”

Which is puzzling as I’m not copying and pasting, rather trying to apply Studio Fade Out.

I’ve been using Audacity for many many years and this error just started after updating, so I think it might be a new bug? I also get this error with other effects, such as EQ. I don’t get these errors all the time, they’re sort of unpredictable, might depend on exactly where I select in the project? On the other hand, once they occur, they will re-occur, in the same place. That is, if I save the project, close Audacity, start it again, reload the project, I’ll get the same error, trying to apply effect in the same area (i.e. I create marks to make it easy to select the area.)

I get the error whether I select a section in all tracks, or a single track.

Unfortunately my projects are huge, 8 to 12 tracks for 3 hours or so. So, not really practical to share and example project. FYi, I record a jam session using a Zoom L-20 multi-track recorder, import the wav files. I use clip boundaries to separate the songs.

Again, I’ve been doing all this for years and never had this error.

Any suggestions for troubleshooting etc would be greatly appreciated.

p.s. Audacity is awesome, and even though I’ve tried other programs (DAWs), I still prefer Audacity, yes even for “mixing.”

I’m not able to reproduce the problem, but try this:

“Edit menu > Preferences > Tracks Behaviors”
Enable the option: “Editing a clip can move other clips”

Thanks very much, that fixed the problem.

Side note: I don’t know _why it fixed it. I would not expect an effect to move any samples or clips, I would only expect an effect to modify the amplitudes of the samples.

Thank you for your help.

Same here. I wouldn’t have expected an effect to move any samples or clips, and I can’t reproduce the problem, but I’m on Linux not Windows.
It would be nice to work out how this is happening, because it looks like a bug.

How do you “create marks”?

sorry for delayed reply, and for imprecise wording. When I said I create marks, what I should have said:

  1. add label at start of song
  2. select all tracks
  3. split (all tracks)
  4. add label at end of song
  5. select all tracks
  6. split (all tracks)

Now I can double click in the song, on any track, and that selects that clip (the song). Then I can hit the Zoom to Selection button.

Thanks for the clarification.
By the way, the current version of Audacity is 2.4.2, and a new version (3.0.0) is due to be released very soon.
The latest version of Audacity is always available via the Audacity website (Click “Check for updates” in the Audacity “Help” menu to visit the website).

Thanks Steve. (Win10/3.1.3) I had recorded a new track title at the End and was trying to paste the next sound at the Home of the track before deleting the original track title. :clapping:

I had the same issue when generating silence between fades. Turning on “editing a clip can move other clips” seems to have resolved the issue, but I feel like that solution is simply a work around hack.