the software is not receiving and audio input from the USB

Audacity + Soundcraft Signature 12 MTK: I’m having trouble using the mixer to record audio into audacity via USB. I’ve configured the AUDIO/MIDI settings and enabled the device, checked the SYSTEMS PREFERENCES:SOUND settings and the meter blips with the sound coming in from the USB cable but when I record on Audacity there’s no waveform forming ie: the software is not receiving and audio input from the USB. I’ve even gone so far as to double check that the sample rates/bit depth were consistent in all settings menus. How do you get the mixer to interact with Audacity?

So I am a Windows guy, so I cannot help you directly. Until a Mac guy comes along, check your microphone permissions. Can you record from your built-in microphone?

Also, is your Audacity up-to-date ? See here: Audacity ® | Download for Mac OS

I hope this helps. :smiley:

I am having the same issue. iMac 21.5 (2017), MacOS 11.2.1 Bin Sur and Audacity 2.4.2 (just downloaded and installed today. I have gone through and (supposedly) verified that all is well with the help section ‘Mac & USB Input Devices’. Sound shows USB Codec receiving input from the USB device, the device is set as the default input, but there is ‘No indication on Audacity input meter’ of sound getting to the program. Sample and bit rates match. Any suggestions?

The fix is buried in the FAQ. The problem is that the new security in Big Sur is not allowing Audacity to have access to the microphone, even though it is through a codec. Go to Apple, System Preferences, Security and Privacy and select Privacy. In the list, select Microphone and allow Audacity access to it. Click on the lock icon, supply your password and all will be well. At least it fixed the problem for me. Hope this helps.

There’s also an “announcement” about it at the top of the macOS section of this forum (See “No recording level” in the announcements here: macOS - Audacity Forum).