The project size exceeds the available free space on the target disk

At first I got this error because my notebook only had 50GB of space left and the project I recorded was already taking 26GB of space in /var/tmp … So I ordered a high-performance 512GB SD card to expand the available storage. It’s formatted in Ext4 btw. But I still get the same error message when trying to save to that SD card. How is that possible?
After copying a couple of files from my internal SSD to the SD card (until i had about 40GB of space left again) I was still not able to save the project to the SD card. I was however able to save it to the SSD then and finally copy it to the SD card.

I would really like to be able to save my projects to the 500GB SD card directly in the future. It worries me that audacity it having issues with that. I’m not even sure if I’ll be able to open and save that project without going through this whole workaround again. Any ideas?

Audacity version: 3.2.1

Windows guy here. Can you post a screenshot of the error message ?

Randomuser111, are not the only one with this problem in Linux.
I have this problem (I’m on Pop Linux, an Ubuntu variant) and it usually happens
when I try to save a file several times to different media. It gave me the “insufficient disk space” on both an external portable drive, and a 256 GB USB flash drive.

After getting the error twice, I decided to save a second copy to the hard drive, just to see
what would happen. NO matter where I tried saving, it said there wasn’t enough space.
I thought I’d gotten a snapshot of the error message, but apparently it hadn’t saved.

I know this sounds like a lack disk space problem, but I assure you there were at least 100 gigs of spare hard disk space on each target. Interestingly, it did not matter what format I used (export to WAV or the inhouse project format). I seemed to get performance issues at the same time. In fact shutting down the software was challenging because it kept wanting to save, and simply couldn’t because of this phantom lacking disk problem.

It finally listened after three or four times of telling it I did NOT want to save before exiting. Fortunately, I had had a chance to save earlier, so I do have a copy of my work.
But it was a near thing. I couldn’t do my usual backup procedures which I did manually.
Still, I prefer not to make too many copies of an extant file, in the theory I might prevent bit rot.

I speculate (wildly, and with zero evidence) that this might not be a disk space problem but an available memory problem, where there isn’t enough memory to spool the file to make a save. It’s also possible that you have a different problem than mine. But it sounds so much like mine I thought I’d post here anyway.

Right now, at the beginning of my edit session, I can’t seem to trigger the error message, or I would have posted one already. Later today if/when I get that message again, I’ll make sure to screen shot it early in the error message period. This way, hopefully the flakiness won’t affect my ability to record the error.