The problem with export mp3 in audacity 3.4.0

Dear specialists! Could you return export of mp3-files as it was before? I’m not at all happy about new. When I try to change file name, it’s impossible to erase “.mp3” from it. I have to rewrite “.mp3” again after changing name. Otherwise, an exported file will be without extension. Or, please, hide “.mp3” in file name, so that I cuold edit it without problems.

I believe they’re working on that…

this will be fixed in 3.4.1 later today.

Hello:
What about the MetaData?
before I would use Alt=3 shortcut key to export as MP3.
then after entering the FieName, it would bring up the Metadata window.
i would enter the Metadata for the first file, Save, and then Set as Default.
NOW, I have to make an extra Click to EDIT MetaData.
Then i enter, Save, and Set as Default.
BUT on the next file I create, after clicking Edit MetaData, the entire window’s fields are BLANK?
What is the point of setting the DEFAULT IF it does NOT read/use it?
And WHy the extra clicks, now?

Thank you! I just liked it better before, but still I can use it.

Excuse me, the problem wasn’t solved completely. It works fine if you click “Export”. If you click “Enter” instead, the problem resumes. I’m used to click just Enter to launch file export, now I have to relearn, why? Please, refine!

I agree. Previous version was simpler (v3.3x)

on v3.4.1 there is no “export” under File. Instead u must click “File|export audio” then u need to click “edit meta data”. These are too many steps

I am also finding exporting frustrating as I export several times a day. When you type a file name it no longer provides similar file names as well as the annoyance of it not automatically showing the metadata to fill in. How do I go back to the previous version please? I can not find it in help. Thank you. Brian

Thank you! Finally it’s solved in Audacity 3.4.2