the Jack and Audacity 2.3.2 sound server

Good morning all,

I start with MAO and I would like to use the server Jack.
I am under Ubuntu 18.04.
Currently Audacity works very well without Jack but as a curiosity I would like to try to see how we operate. To do this, I installed:

  • pavucontrol,
  • qjackctl and jaccd.
    When I open Audacity in Preferences / Devices we see the host ALSA (and I can not find the jackd) screenshot below:

    In the documentation, it is specified to ‘arm’ Audacity then to pause / record it so that jack connects to Audio Port?

How can I do ? I miss libraries or other packages to install.

Thank you in advance for your help.

What is “MAO”?

You need to start the Jack server before launching Audacity.

The easiest way to start the Jack server, is to launch QjackCtl, and click the “Start” button. Ensure that Jack is running without “xruns”. If Jack fails to run, or you get continuous xruns, you will need to adjust the Jack settings (in QjackCtl) until you find settings that enable Jack to run reliably without xruns.

I think I found.

Here are the screenshots:\u003daWUewjq9dw9A/OCgkt6cswj7U\u003d0e6WwzEPFPyo/UsORLT2bQb7a

Thank you kindly tell me if it is consistent. :slight_smile:


Those page addresses don’t work. They just say “we’re sorry, something went very wrong”.
See here for how to attach a picture to your post:

Have you tried doing this?

Capture d’écran de 2019-10-13 10-14-25.resized.png
Capture d’écran de 2019-10-13 10-14-37.resized.png

I’m not able to read what they say.

Have you tried doing this?

Good morning all,

I continued to watch various forums on the issue.
I noted that ‘Jack only sees Audacity in reading under the name of Audio Port’
This is how I proceeded:

  • open qjackctl and start
  • I started Audacity for reading
  • then break
  • then I made a recording
    I got to put in place of Alsa or Oss Jack as shown in the screenshot:
    Capture d’écran de 2019-10-14 11-41-50.resized.png
    When I want to record the sound, it crashes and asks me to change the host, etc.
    I think there are difficulties to install qjackctl with Ubunt distribution 18.04 LTS;

It works fine for me.


Thanks Steve for the answer.
Maybe the connection with Port-Audio is wrong?
Can I show a screenshot of the connection?

The most common problem when using Jack, is getting Jack to run with the selected device without xruns. Unfortunately, that’s something that we are not able to offer much help with as the settings vary from machine to machine. If Jack is not running reliably, or if there are any problems with Jack Audio System, you need to fix those problems first. Don’t bother even trying to use Audacity with Jack until you have the jack server running reliably.

Once Jack is running correctly, then using Audacity with jack is very simple. All you need to do is:

  1. Launch Audacity
  2. Ensure that “Jack Audio System” is selected as the “host” (see:

By default, the recording input and outputs in the Device Toolbar are set to “system”. The “system” input / outputs correspond to the inputs / outputs of the audio device that you configured when setting up Jack.

Why do you need to use Jack?

Thank you steve for this valuable information.
I would use Qlackctl with Audacity out of curiosity.
In fact, I will continue to use Audacity exclusively for the moment.
Thanks again for your help.