I have a Mac Mini running OS 10.7.5 and Audacity 2.0.3. I just bought a TEAC TN300 USB Turntable but I cannot get Audacity to “hear” the sound coming from the turntable. The turntable is plugged directly into the Mac via USB and the Mac is hooked into an Onkyo receiver and played through the CABL/SAT input. When I play anything that comes from the computer itself, like a video on Youtube, the sound works fine.In the System Preferences/Sound/Input I can see the sound coming from the turntable on the Input Level scale but I can’t get a signal into Audacity no matter what I set the input to nor can I get sound via the CABL/SAT input. Any ideas?

Connect the turntable to the computer with the USB cable before you launch Audacity (if Audacity is opened first you will need to “Rescan audio devices” from the Transport menu).
Then select the turntable (USB option) as the recording device in the device toolbar.
To play the turntable ‘through’ your computer, enable “Software playthrough” in the Transport menu, and ensure that your normal playback device is set as the playback device in the device toolbar.

Note that software playthrough is not instant. When playing through your computer via software, it takes a little time (often about half a second) for the sound going in to come back out.

More information here: http://manual.audacityteam.org/man/recording_with_usb_turntables.html

2.0.3 is very old now. You can get the current 2.1.2 release from http://www.audacityteam.org/download/mac.


Hi Gale and Steve,

I downloaded the newest version of Audacity. Even though I’m getting a meter reading in the Mini’s Settings/Sound window, still nothing in Audacity and no output through my speakers. I’ve tried both the headphones port and the USB Audio Codec options, still nothing. Could it be my codec?
2016-09-20 04.53.19 pm.png

Here are my Audacity settings - I’ve tried every combination…
2016-09-20 04.56.23 pm.png

There is only one pair of settings that will work - USB Audio CODEC as the Audacity recording device
and Built-in output as Audacity playback device. Connect the turntable before you launch Audacity.

Software Playthrough should work if you press the Red record button. If you want to hear without recording, then as well as enabling software playthrough in Audacity, you must click in the Recording Meter:

so that it no longer says “Click to Start Monitoring”.

If Software Playthrough does not work, try LineIn from http://www.rogueamoeba.com/freebies/.


PROBLEM SOLVED!! Thank you Gale!!

You’re welcome. Were you trying to listen without recording? It may help other users to know.


Very frustrating…
I did all the above but my TEAC TN300 has no audio on my PC speakers :frowning:

Generate > Tone in Audacity and make sure you can hear that. If you can, double-check you are choosing the USB Audio CODEC for the turntable as Audacity Recording Device and the Recording Level is turned up.

If you are trying to listen without recording, remember to click in the Recording Meter so it does not say “Click to Start Monitoring”.