Taking long to open (sometimes unresponsive)


I recently updated Mac OS X from El Capitán (I believe) to macOS Mojave 10.14.6.

I also updated my Audacity to 2.3.2.

But now I’m having trouble with Audacity being slow to open, and sometimes it becomes unresponsive. Unresponsive as in the Activity Monitor shows “Not Responsive” for Audacity, and it doesn’t open at all.

I’ve gone to /Application Support/Audacity and removed all the contents of that folder so nothing remained from the older Audacity version that I had previously.

Today Audacity again became unresponsive, so I went to /Application Support/Audacity and removed the /SessionData/ contents, and that seemed to work, but usually the SessionData contents disappear when I shut down Audacity.

The files I’m working with aren’t large, just 3-4 minutes of audio. But the slow loading happens with just opening Audacity, and with opening an Audacity project. Only opening Audacity often goes faster. Opening a project can take up to 30 seconds, and sometimes becomes unresponsive. If it becomes unresponsive, shutting down Audacity/force quit doesn’t seem to help.

I don’t use special plugins or effects, just plain vanilla Audacity.

I tried unchecking VST and other things in Effects > Enable Effects but nothing changed.

Any ideas on how I could speed things up?

Have I forgotten to remove something from my old Audacity setup?



I went into Preferences > Effects and removed everything except Audio Unit (top one). After that, I could open Audacity, and individual projects, quickly (1-3 seconds).

Then I went back in and checked all the effects again, and now the projects are opening fine, but opening up just Audacity takes time.

When I remove them again (except Audio Unit), just Audacity opens up fast again.

When I go back and check all the effects, and quit Audacity, it opens up fast again. But if I open a project (fast), close Audacity, and then open up just Audacity, it takes long again. If I remove the effects, it opens up fast again.

I went to try and open up some older Audacity projects to make sure things aren’t cached, and enabling all the effects again makes the non-cached project take a long time to open.

When I remove the effects once again, and go to a different older project (in a different folder), it takes a long time again, but opening a project in the same folder goes fast, even with all the effects turned on.

So for example:

  1. /Project X/ - opening goes fast after I disable and enable effects
  2. /Project Y/ - going to this folder and opening an audacity .aup file goes slow, but disable/enable seems to make it go fast again (even when I’m opening a previously unopened file in this folder

Switching folder from Project X to Project Y, with or without effects, seems to make it take long to load again, but if I open a file in the same folder, without many of the effects, it goes fast.

Is any of this making sense?

First the obvious. Close everything and Apple > Shut Down… Not Restart. Full Shutdown. See how long the little spinning daisy hangs before the machine actually shuts down. Wait and bit and Start.

How much space do you have on the machine?

Go (top of the desktop) > Computer > Macintosh HD > File > Get INFO.
Capacity, Available, Used.

Screen Shot 2019-09-27 at 13.27.49.png
You can look at the system struggling and see if you can find anything wrong.

Go (top of the desktop) > Utilities > Activity Monitor.

Then launch or try to launch Audacity.

CPU will tell you if one application is going nuts and hogging the machine.
DISK is another place to look for hogging.

Do you use iCloud or other on-line storage service?

Anything odd happen at any of those steps?

I had a recent event where something I caught from the internet as Firefox Web Content was taking up 99% of the my machine resources. It wasn’t one of mine. Did you get Audacity from here?




Thanks for the reply.

Available space is 569gb.

Shutting down happens smoothly. No problems there.

At idle Activity Monitor says I’m at around 2% CPU, so no application is taking up too much, and other than Audacity, other applications are running smoothly and opening quickly.

I do use iCloud, but mostly for storing a few documents.

Yes, I believe I downloaded Audacity from Fosshub.

After reboot (with almost all effects removed), Audacity is opening quickly again, so I don’t know if it could be some kind of complication with another software, or just disabling most of the effects (and it not searching in some place where the old Audacity installation was, although the old install was in the same place, as far as I know).

If any other ideas pop up, let me know.

I’ll post here if it slows down again :slight_smile:

Thanks again!

I do use iCloud, but mostly for storing a few documents.

So it’s a “mounted filesystem” (in Linux-Speak) on your machine. It looks just like any other disk drive to Apps. Except it’s not. It has network delays and negotiations missing from your local hard drive.

Unless somebody corrects me, Audacity doesn’t deal well with networks. Everybody who tries to run Audacity on a machine over There while they sit at a machine over Here comes away with tales of odd instability.

That’s the first place I would look. Do you know how to manage networks in Mac Preferences? I found it handy to know how to split my Macs from the Outside World during maintenance and repairs.


I also did use iCloud on El Capitán, so I didn’t just start using iCloud. Unless macOS Mojave uses iCloud in a different way?

Is there a help/wiki file somewhere that explains how to manage networks in this way? If so, feel free to link :slight_smile:

Unless macOS Mojave uses iCloud in a different way?

I don’t use iCloud, yet, so I couldn’t say.

Apple (upper left) > System Preferences > Network.

That’s this machine, right this second, on WiFi and no other connection. Other machines have hard-wired cable selections lit up. This setting should be supervisory. If you kill a network connection, the machine should drop off-line regardless how many other apps and services are trying to connect.


All right. I have the same setup, except instead of Wi-Fi I’m on a wired/ethernet connection (that goes to my router).

Is there anything I need to check here for Audacity?

Audacity is still starting up fast with almost all effects disabled.

I just enabled some of the effects in Audacity again, and after a while I couldn’t open Audacity at all. I had to log out and log in again, and then it opened.

I just tried uninstalling Audacity 2.3.2 and re-installing 2.3.1. I’ll report back tomorrow. So far it works fine, but but…

Thanks again for the help and patience. I do appreciate it. I really enjoy using Audacity.

Same thing with 2.3.1.

Works fine after a fresh login/reboot, but later in the day it becomes unresponsive.